Bug 260792 - emulators/wine-proton patch-sysinfo missing
Summary: emulators/wine-proton patch-sysinfo missing
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Some People
Assignee: Gerald Pfeifer
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-12-29 10:52 UTC by Patrick Mackinlay
Modified: 2021-12-30 18:05 UTC (History)
2 users (show)

See Also:
iwtcex: maintainer-feedback+


Attachments
patch-sysinfo from emulators/wine/ (2.21 KB, patch)
2021-12-29 11:56 UTC, Patrick Mackinlay
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Patrick Mackinlay 2021-12-29 10:52:00 UTC
Building wine-proton-6.3.2_3 on FreeBSD fails with a compile error:


# MAKE_JOBS_UNSAFE=yes make
===>  Building for wine-proton-6.3.2_3
cd /usr/ports/emulators/wine-proton/work/wine-97f962cd469ee9b9b68d32e79849bf94cfe15581 && gmake depend
gmake[1]: Entering directory '/usr/ports/emulators/wine-proton/work/wine-97f962cd469ee9b9b68d32e79849bf94cfe15581'
./tools/makedep
gmake[1]: Leaving directory '/usr/ports/emulators/wine-proton/work/wine-97f962cd469ee9b9b68d32e79849bf94cfe15581'
gmake[1]: Entering directory '/usr/ports/emulators/wine-proton/work/wine-97f962cd469ee9b9b68d32e79849bf94cfe15581'
tools/winegcc/winegcc -o dlls/ntdll/ntdll.so --wine-objdir . -m64 -fPIC -fasynchronous-unwind-tables -munix -shared \
  dlls/ntdll/ntdll.spec -nodefaultlibs dlls/ntdll/unix/cdrom.o dlls/ntdll/unix/debug.o \
  dlls/ntdll/unix/env.o dlls/ntdll/unix/esync.o dlls/ntdll/unix/file.o dlls/ntdll/unix/fsync.o \
  dlls/ntdll/unix/loader.o dlls/ntdll/unix/process.o dlls/ntdll/unix/registry.o \
  dlls/ntdll/unix/security.o dlls/ntdll/unix/serial.o dlls/ntdll/unix/server.o \
  dlls/ntdll/unix/signal_arm.o dlls/ntdll/unix/signal_arm64.o dlls/ntdll/unix/signal_i386.o \
  dlls/ntdll/unix/signal_x86_64.o dlls/ntdll/unix/sync.o dlls/ntdll/unix/system.o \
  dlls/ntdll/unix/tape.o dlls/ntdll/unix/thread.o dlls/ntdll/unix/virtual.o \
  dlls/ntdll/unix/version.o dlls/winecrt0/libwinecrt0.a libs/port/libwine_port.a -lpthread \
  -lprocstat -L/usr/local/lib -fstack-protector-strong -Wl,-rpath=/usr/local/lib/gcc10 -L/usr/local/lib/gcc10 
/usr/local/bin/ld: dlls/ntdll/unix/virtual.o: in function `virtual_get_system_info':
virtual.c:(.text+0x4f57): undefined reference to `sysinfo'
collect2: error: ld returned 1 exit status
winegcc: /usr/local/bin/gcc10 failed
gmake[1]: *** [Makefile:96177: dlls/ntdll/ntdll.so] Error 2
gmake[1]: Leaving directory '/usr/ports/emulators/wine-proton/work/wine-97f962cd469ee9b9b68d32e79849bf94cfe15581'
*** Error code 1

Stop.
make: stopped in /usr/ports/emulators/wine-proton




This is the same error that affected the wine port as was fixed in
https://bugs.freebsd.org/bugzilla//show_bug.cgi?id=260165

Just copying the patch-sysinfo from the wine port to the wine-proton/files directory fixes the problem
Comment 1 Alex S 2021-12-29 11:04:27 UTC
I can't approve a patch if it's not attached (there is an attachment-specific flag).
Comment 2 Patrick Mackinlay 2021-12-29 11:56:02 UTC
Created attachment 230534 [details]
patch-sysinfo from emulators/wine/

Attached the missing patch copied from emulators/wine/
Comment 3 Alex S 2021-12-29 12:08:41 UTC
Gerald, would you mind copying your patch to emulators/wine-proton as well?
Comment 4 Gerald Pfeifer freebsd_committer 2021-12-30 11:38:05 UTC
I'll take care...
Comment 5 commit-hook freebsd_committer 2021-12-30 13:27:17 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=9b46ada11cb643d07d33cd5ce10ae155fbcd0e3e

commit 9b46ada11cb643d07d33cd5ce10ae155fbcd0e3e
Author:     Gerald Pfeifer <gerald@FreeBSD.org>
AuthorDate: 2021-12-30 11:32:47 +0000
Commit:     Gerald Pfeifer <gerald@FreeBSD.org>
CommitDate: 2021-12-30 13:23:15 +0000

    emulators/wine-proton: Fix build with devel/libsysinfo present

    Port b75f3b5a79927f27605bee328c36d9d7d8b425ec from emulators/wine:

      This back ports the patch I pushed upstream and that wine-devel has
      inherited from there a few months ago. It will go away with the next
      major release.

    PR:             260792
    Requested by:   iwtcex@gmail.com (maintainer)
    Submitted by:   Patrick Mackinlay <freebsd.68fba@nospam.spacesurfer.com>

 emulators/wine-proton/files/patch-sysinfo (new) | 72 +++++++++++++++++++++++++
 1 file changed, 72 insertions(+)
Comment 6 Gerald Pfeifer freebsd_committer 2021-12-30 13:31:32 UTC
This should do it. Please advise if there's anything else.
Comment 7 Alex S 2021-12-30 18:05:47 UTC
Thanks! That works as intended.