Bug 260811 - x11/mate-screensaver 1.26.1 fails to open login panel
Summary: x11/mate-screensaver 1.26.1 fails to open login panel
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-gnome (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-12-30 01:55 UTC by Tomoaki AOKI
Modified: 2022-01-04 13:01 UTC (History)
3 users (show)

See Also:
bugzilla: maintainer-feedback? (gnome)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tomoaki AOKI 2021-12-30 01:55:47 UTC
After upgrading from 1.26.0 to 1.26.1, mate-screensaver no longer opens login panel, thus need killing mate-screensaver process from any of vty to go back to X screen.

I suspect prerequisite(s) for commit [1] upstream does not met or some additional (manual, possibly per-user) configurations are needed.

[1] https://github.com/mate-desktop/mate-screensaver/commit/ed6e6065bf0e85b64317b5a34b9f7a36a0c839a6

[2] https://github.com/mate-desktop/mate-screensaver/commits/master/
Comment 1 Eric Turgeon freebsd_committer 2021-12-30 14:52:52 UTC
I should have tested the screen lock before committing. Looks like the new implementation of pam is the problem.
Comment 2 Eric Turgeon freebsd_committer 2021-12-31 23:05:06 UTC
I made a GitHub issue  https://github.com/mate-desktop/mate-screensaver/issues/272 with the information I have so far.

I will be able to patch the port to fix the issue temporarily.

But a proper fix will need to be done upstream.
Comment 3 commit-hook freebsd_committer 2022-01-01 01:35:26 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=9d56cc6b40e2694687d6c22c46bcf64cd43b2d81

commit 9d56cc6b40e2694687d6c22c46bcf64cd43b2d81
Author:     Eric Turgeon <ericbsd@FreeBSD.org>
AuthorDate: 2022-01-01 00:11:27 +0000
Commit:     Eric Turgeon <ericbsd@FreeBSD.org>
CommitDate: 2022-01-01 01:34:53 +0000

    x11/mate-screensaver: Fix helper option

    This patch revert changes that broke --enable-authentication-scheme and --with-passwd-helper

    PR:             260811
    Reported by:    Tomoaki AOKI

 x11/mate-screensaver/Makefile                      |   1 +
 .../files/patch-src_gs-auth-helper.c (new)         | 211 +++++++++++++++++++++
 2 files changed, 212 insertions(+)
Comment 4 Eric Turgeon freebsd_committer 2022-01-01 01:37:36 UTC
This patch should do it for now.
Comment 5 Tomoaki AOKI 2022-01-02 00:36:24 UTC
(In reply to Eric Turgeon from comment #4)

Thanks!
Confirmed working again on git src main 398c88c7582a and git src stable/13 375fdb6e161e, both on amd64.

Hope upstream add an option to toggle this behaviour at least until we can (hopefully) find any way to support new method.
Possibly, security/pam-helper needs updating?
Comment 6 rkoberman 2022-01-02 07:25:22 UTC
This should be fixed in 1.26.1_1. Try updating to that.
Comment 7 Eric Turgeon freebsd_committer 2022-01-02 17:21:41 UTC
(In reply to Tomoaki AOKI from comment #5)
I do not think it is security/pam-helper the problem.