Bug 261238 - 13-RELEASE installation media hang on booting ThinkCentre M91p
Summary: 13-RELEASE installation media hang on booting ThinkCentre M91p
Status: New
Alias: None
Product: Base System
Classification: Unclassified
Component: kern (show other bugs)
Version: 13.0-RELEASE
Hardware: amd64 Any
: --- Affects Some People
Assignee: freebsd-bugs (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-01-16 04:05 UTC by Greg Lehey
Modified: 2022-01-21 01:34 UTC (History)
1 user (show)

See Also:


Attachments
Photo of boot screen after failure (90.90 KB, image/jpeg)
2022-01-16 04:05 UTC, Greg Lehey
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Greg Lehey freebsd_committer 2022-01-16 04:05:37 UTC
Created attachment 231033 [details]
Photo of boot screen after failure

I have been unable to boot FreeBSD 13.0-RELEASE installation media on a Lenovo ThinkCentre 91p.  The boot process displays EFI framebuffer information and then hangs.  I have tried this with standard boot, "safe mode" boot, boot to single user, and it always hangs in the same place.  The -v option doesn't produce any additional information. I have tried this with the memstick image (https://download.freebsd.org/releases/amd64/amd64/ISO-IMAGES/13.0/FreeBSD-13.0-RELEASE-amd64-memstick.img) and the DVD image (https://download.freebsd.org/releases/amd64/amd64/ISO-IMAGES/13.0/FreeBSD-13.0-RELEASE-amd64-dvd1.iso) with the same results.

This is not a general ThinkCentre issue.  The same media boot fine on a ThinkCentre M93p.  It is also not an obvious hardware defect; disks with older versions of FreeBSD also work fine.
Comment 1 Graham Perrin 2022-01-18 17:35:59 UTC
(In reply to Greg Lehey from comment #0)

> 13.0-RELEASE 

For diagnosis, please (without installing) tell whether the affected computer can boot from either of the following: 

* an installer for 14.0-CURRENT
* an installer for 13.0-STABLE

Respectively: 

<https://www.freebsd.org/where/#_freebsd_14_0_current>
<https://www.freebsd.org/where/#_freebsd_13_0_stable>

If either installer does boot the computer, then this is probably a duplicate of bug 209821. 

(Compare your photograph with my December 2020 photograph in bug 255073.)
Comment 2 Graham Perrin 2022-01-18 17:37:15 UTC
(In reply to Greg Lehey from comment #0)

> Lenovo ThinkCentre 91p

Can you describe the graphics hardware? Thanks.
Comment 3 Greg Lehey freebsd_committer 2022-01-21 01:32:29 UTC
(In reply to Graham Perrin from comment #1)

I have tried this now with 13-STABLE and 14-CURRENT, specifically FreeBSD-13.0-STABLE-amd64-20211230-3684bb89d52-248759-memstick.img and FreeBSD-14.0-CURRENT-amd64-20211230-b406897911e-252039-memstick.img.  In each case the system boots fine.

And yes, I agree that this is a duplicate of https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=209821.  I suspect that comment 66 has the clue:

"I think there were two reasons why UEFI boot froze on some systems. Before the changes in 13-STABLE and 14-CURRENT, the kernel needed to be loaded to a specific physical memory location. Copying the kernel to a specific location in memory could cause problems"

On the other hand, we have a second problem: the original 13.0-RELEASE image is still on the download site, and looking at 209821 it seems that a large number of systems are affected.  So I don't think it's appropriate to just close the bug.  Somehow we need to get usable boot media on the download sites.  My thought would be to upgrade to a 13-STABLE system, but that's a question for Releng.  I'll contact them separately.
Comment 4 Greg Lehey freebsd_committer 2022-01-21 01:34:47 UTC
(In reply to Graham Perrin from comment #2)

This is probably no longer relevant, but this machine has on-board graphics. From dmesg:

vgapci0: <VGA-compatible display> port 0xf000-0xf03f mem 0xfe000000-0xfe3fffff,0xd0000000-0xdfffffff irq 16 at device 2.0 on pci0
vgapci0: Boot video device