Bug 261257 - Mk: CMake Error: Parse error in command line argument: _THREAD_SAFE with mail/evolution 3.42.3
Summary: Mk: CMake Error: Parse error in command line argument: _THREAD_SAFE with mail...
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Ports Framework (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: freebsd-gnome (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-01-16 22:59 UTC by Neel Chauhan
Modified: 2022-01-24 22:25 UTC (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Neel Chauhan freebsd_committer 2022-01-16 22:59:46 UTC
When I attempt to update mail/evolution to 3.42.2 or 3.42.3, I get an error like this:

CMake Error: Parse error in command line argument: _THREAD_SAFE                 
 Should be: VAR:type=value                                                      
                                                                                
CMake Error at /usr/local/share/cmake/Modules/Internal/CheckSourceRuns.cmake:94 (try_run):
  Failed to configure test project build system.
Call Stack (most recent call first):
  /usr/local/share/cmake/Modules/CheckCSourceRuns.cmake:76 (cmake_check_source_runs)
  CMakeLists.txt:718 (CHECK_C_SOURCE_RUNS)


-- Configuring incomplete, errors occurred!                                     
See also "/wrkdirs/usr/ports/mail/evolution/work/.build/CMakeFiles/CMakeOutput.log".
See also "/wrkdirs/usr/ports/mail/evolution/work/.build/CMakeFiles/CMakeError.log".
*** Error code 1                                                                

There must be some issue with the Mk framework, since OpenBSD has mail/evolution 3.42.3.

My updates are not committed for this issue.
Comment 1 Tobias C. Berner freebsd_committer 2022-01-19 11:57:42 UTC
Moin moin 

I doubt Mk/ is responsible for this. Can you provide the diff required for this error to be reproduced?


mfg Tobias
Comment 2 Adriaan de Groot freebsd_committer 2022-01-24 22:25:28 UTC
I see that 3.42.3 has landed, so I'll call this "mysteriously fixed by nc@"