Bug 262707 - devel/llvm{14,-devel}: use in-tree libunwind on 13.1 and newer
Summary: devel/llvm{14,-devel}: use in-tree libunwind on 13.1 and newer
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Brooks Davis
URL:
Keywords:
: 262887 (view as bug list)
Depends on:
Blocks:
 
Reported: 2022-03-21 17:54 UTC by Piotr Kubaj
Modified: 2022-04-20 23:17 UTC (History)
1 user (show)

See Also:


Attachments
patch (1.06 KB, patch)
2022-03-21 17:54 UTC, Piotr Kubaj
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Piotr Kubaj freebsd_committer freebsd_triage 2022-03-21 17:54:08 UTC
Created attachment 232614 [details]
patch

Verified to build successfully.
Comment 1 commit-hook freebsd_committer freebsd_triage 2022-03-25 22:51:11 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=04e074c6fd452983ccfd931de0c43263d27fe1f3

commit 04e074c6fd452983ccfd931de0c43263d27fe1f3
Author:     Brooks Davis <brooks@FreeBSD.org>
AuthorDate: 2022-03-25 22:49:58 +0000
Commit:     Brooks Davis <brooks@FreeBSD.org>
CommitDate: 2022-03-25 22:49:58 +0000

    devel/llvm14: Update to 14.0.0 release

    Avoid a dependency of libunwind on sufficently recent systems where
    the installed unwind.h can be found.

    PR:             262707
    Reported by:    pkubaj

 devel/llvm14/Makefile | 11 +++++++----
 devel/llvm14/distinfo |  6 +++---
 2 files changed, 10 insertions(+), 7 deletions(-)
Comment 2 commit-hook freebsd_committer freebsd_triage 2022-03-28 18:00:45 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=f7b0e813f098ce7bafad184b77f614b5609d47a1

commit f7b0e813f098ce7bafad184b77f614b5609d47a1
Author:     Brooks Davis <brooks@FreeBSD.org>
AuthorDate: 2022-03-28 17:58:50 +0000
Commit:     Brooks Davis <brooks@FreeBSD.org>
CommitDate: 2022-03-28 17:58:50 +0000

    devel/llvm14: Fix build on 13.0

    The guards for using system unwind.h appear to be incorrect so revert
    that part of 04e074c6fd452983ccfd931de0c43263d27fe1f

    PR:             262707

 devel/llvm14/Makefile | 9 +++------
 1 file changed, 3 insertions(+), 6 deletions(-)
Comment 3 Eric Camachat 2022-03-28 20:58:25 UTC
*** Bug 262887 has been marked as a duplicate of this bug. ***
Comment 4 commit-hook freebsd_committer freebsd_triage 2022-03-29 16:43:18 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=452e507d4c92a28382a6181bb869b656690c47f2

commit 452e507d4c92a28382a6181bb869b656690c47f2
Author:     Brooks Davis <brooks@FreeBSD.org>
AuthorDate: 2022-03-29 16:39:00 +0000
Commit:     Brooks Davis <brooks@FreeBSD.org>
CommitDate: 2022-03-29 16:41:35 +0000

    devel/llvm-devel: Update to a new snapshot.

    Avoid a dependency of libunwind on sufficently recent systems where
    the installed unwind.h can be found.

    PR:             262707

 devel/llvm-devel/Makefile          | 14 +++++----
 devel/llvm-devel/Makefile.COMMANDS |  1 +
 devel/llvm-devel/Makefile.snapshot |  4 +--
 devel/llvm-devel/distinfo          |  6 ++--
 devel/llvm-devel/pkg-plist         | 61 ++++++++++++++++++++++++++++++++------
 5 files changed, 66 insertions(+), 20 deletions(-)
Comment 5 commit-hook freebsd_committer freebsd_triage 2022-04-20 23:17:25 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=3a7c192dc40b51cc8d08f04ffe69cee13637c4f6

commit 3a7c192dc40b51cc8d08f04ffe69cee13637c4f6
Author:     Brooks Davis <brooks@FreeBSD.org>
AuthorDate: 2022-04-20 23:17:01 +0000
Commit:     Brooks Davis <brooks@FreeBSD.org>
CommitDate: 2022-04-20 23:17:01 +0000

    devel/llvm14: enable COMPILER_RT on riscv64

    Also use the base system unwind.h when appropriate.

    PR:             262707, 263414
    Submitted by:   pkubaj

 devel/llvm14/Makefile | 43 +++++++++++++++++++++++++++++++++----------
 1 file changed, 33 insertions(+), 10 deletions(-)