Bug 262762 - www/redmine42: Unable to start do to log directory
Summary: www/redmine42: Unable to start do to log directory
Status: Closed Overcome By Events
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Mikael Urankar
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-03-24 16:44 UTC by Goran Mekić
Modified: 2022-06-11 11:41 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (mikael)


Attachments
redmine.diff (822 bytes, patch)
2022-03-24 16:44 UTC, Goran Mekić
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Goran Mekić 2022-03-24 16:44:10 UTC
Created attachment 232677 [details]
redmine.diff

Although -c in thin should take the process to WWWDIR, starting redmine complains it can not create /log. The full error is:

Traceback (most recent call last):
	13: from /usr/local/bin/thin:25:in `<main>'
	12: from /usr/local/bin/thin:25:in `load'
	11: from /usr/local/lib/ruby/gems/2.7/gems/thin-1.8.1/bin/thin:6:in `<top (required)>'
	10: from /usr/local/lib/ruby/gems/2.7/gems/thin-1.8.1/lib/thin/runner.rb:159:in `run!'
	 9: from /usr/local/lib/ruby/gems/2.7/gems/thin-1.8.1/lib/thin/runner.rb:203:in `run_command'
	 8: from /usr/local/lib/ruby/gems/2.7/gems/thin-1.8.1/lib/thin/controllers/controller.rb:62:in `start'
	 7: from /usr/local/lib/ruby/gems/2.7/gems/thin-1.8.1/lib/thin/daemonizing.rb:56:in `daemonize'
	 6: from /usr/local/lib/ruby/2.7/fileutils.rb:211:in `mkdir_p'
	 5: from /usr/local/lib/ruby/2.7/fileutils.rb:211:in `each'
	 4: from /usr/local/lib/ruby/2.7/fileutils.rb:226:in `block in mkdir_p'
	 3: from /usr/local/lib/ruby/2.7/fileutils.rb:226:in `reverse_each'
	 2: from /usr/local/lib/ruby/2.7/fileutils.rb:228:in `block (2 levels) in mkdir_p'
	 1: from /usr/local/lib/ruby/2.7/fileutils.rb:250:in `fu_mkdir'
/usr/local/lib/ruby/2.7/fileutils.rb:250:in `mkdir': Read-only file system @ dir_s_mkdir - /log (Errno::EROFS)


Tweaking the /usr/local/etc/rc.d/redmine like I did (included in the uploaded file) the error goes away and everything works, but I'm not too happy about it.
Comment 1 Mikael Urankar freebsd_committer 2022-03-28 08:42:26 UTC
How do you start redmine? I can't reproduce your problem here.
Comment 2 Goran Mekić 2022-03-28 08:46:58 UTC
service redmine restart
Comment 3 Mikael Urankar freebsd_committer 2022-03-28 08:48:21 UTC
And where are these messages printed?
Comment 4 Goran Mekić 2022-03-28 08:50:46 UTC
stderr
Comment 5 Goran Mekić 2022-03-28 08:53:50 UTC
I don't know if it makes any difference, but it's in a jail provisioned via this ansible role: https://github.com/mekanix/jail-redmine/tree/master/ansible/roles/redmine
Comment 6 Goran Mekić 2022-03-28 08:57:03 UTC
One more thing is changed compared to default port options which I don't think influences this error is that I'm using PostgreSQL instead of MySQL. The full info on the packages is:

pkg info redmine42
redmine42-4.2.4_1
Name           : redmine42
Version        : 4.2.4_1
Installed on   : Mon Mar 28 10:46:31 2022 CEST
Origin         : www/redmine42
Architecture   : FreeBSD:13:*
Prefix         : /usr/local
Categories     : www
Licenses       : GPLv2
Maintainer     : mikael@FreeBSD.org
WWW            : https://www.redmine.org/
Comment        : Flexible project management web application
Options        :
	MARKDOWN       : on
	MYSQL          : off
	POSTGRESQL     : on
	RMAGIC         : on
	THIN           : on
Annotations    :
	cpe            : cpe:2.3:a:redmine:redmine:4.2.4:::::freebsd13:x64:1
	repo_type      : binary
	repository     : tilda
Flat size      : 12.7MiB
Description    :
Redmine is a flexible project management web application
written using Ruby on Rails framework, it is cross-platform
and cross-database.

Feature Overview:
* Multiple projects support
* Flexible role based access control
* Flexible issue tracking system
* Gantt chart and calendar
* News, documents & files management
* Feeds & email notifications
* Per project wiki
* Per project forums
* Time tracking
* Custom fields for issues, time-entries, projects and users
* SCM integration (SVN, CVS, Git, Mercurial, Bazaar and Darcs)
* Issue creation via email
* Multiple LDAP authentication support
* User self-registration support
* Multilanguage support
* Multiple databases support

WWW: https://www.redmine.org/