Bug 263689 - cad/veroroute: desktop file has wrong path for executable
Summary: cad/veroroute: desktop file has wrong path for executable
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Yuri Victorovich
URL: https://sourceforge.net/p/veroroute/t...
Keywords:
Depends on:
Blocks:
 
Reported: 2022-04-30 18:24 UTC by Torfinn Ingolfsen
Modified: 2022-04-30 18:45 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (yuri)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Torfinn Ingolfsen 2022-04-30 18:24:04 UTC
Installed cad/veroroute 2.20,1 from a package. The installed desktop file (/usr/local/share/applications/veroroute.desktop) refers to the executable in /usr/bin:
tingo@kg-core2:~ $ grep Exec /usr/local/share/applications/veroroute.desktop
Exec=/usr/bin/veroroute

Obviously, this won't work as the program is installed in /usr/local/bin:
tingo@kg-core2:~ $ which veroroute
/usr/local/bin/veroroute

This on
tingo@kg-core2:~ $ freebsd-version -ku
13.0-RELEASE-p11
13.0-RELEASE-p11
tingo@kg-core2:~ $ uname -a
FreeBSD kg-core2.kg4.no 13.0-RELEASE-p11 FreeBSD 13.0-RELEASE-p11 #0: Tue Apr  5 18:54:35 UTC 2022     root@amd64-builder.daemonology.net:/usr/obj/usr/src/amd64.amd64/sys/GENERIC  amd64
Comment 1 Yuri Victorovich freebsd_committer 2022-04-30 18:42:45 UTC
(In reply to Torfinn Ingolfsen from comment #0)

Torfinn,

Thanks for the report.

The issue is now fixed in the latest version of the port 2.25.
Comment 2 commit-hook freebsd_committer 2022-04-30 18:43:26 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=9308b879e2359aad90de076eb1b144da322e00b3

commit 9308b879e2359aad90de076eb1b144da322e00b3
Author:     Yuri Victorovich <yuri@FreeBSD.org>
AuthorDate: 2022-04-30 18:40:24 +0000
Commit:     Yuri Victorovich <yuri@FreeBSD.org>
CommitDate: 2022-04-30 18:42:35 +0000

    cad/veroroute: Fix paths in .desktop file

    PR:             263689
    Reported by:    Torfinn Ingolfsen <tingox+freebsd@gmail.com>

 cad/veroroute/Makefile | 4 ++++
 1 file changed, 4 insertions(+)
Comment 3 commit-hook freebsd_committer 2022-04-30 18:45:27 UTC
A commit in branch 2022Q2 references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=99f7d974fa133ef82d6468c92d98dd298e23fb13

commit 99f7d974fa133ef82d6468c92d98dd298e23fb13
Author:     Yuri Victorovich <yuri@FreeBSD.org>
AuthorDate: 2022-04-30 18:40:24 +0000
Commit:     Yuri Victorovich <yuri@FreeBSD.org>
CommitDate: 2022-04-30 18:44:52 +0000

    cad/veroroute: Fix paths in .desktop file

    PR:             263689
    Reported by:    Torfinn Ingolfsen <tingox+freebsd@gmail.com>

    (cherry picked from commit 9308b879e2359aad90de076eb1b144da322e00b3)

 cad/veroroute/Makefile | 4 ++++
 1 file changed, 4 insertions(+)