Bug 263806 - Firefox crashes on first click
Summary: Firefox crashes on first click
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-ports-bugs (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-05-06 06:15 UTC by Jürgen Weber
Modified: 2022-05-14 13:51 UTC (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jürgen Weber 2022-05-06 06:15:25 UTC
After the most recent update Firefox on each start crashes on the first click, e.g. on the hamburger menu.

XFCE4 over RDP (xrdp)
13.0-RELEASE-p8
Comment 1 Joel Bodenmann 2022-05-06 13:37:44 UTC
Not sure if this is directly related or not but www/firefox 100.0_3,2 is immediately crashing on my 13.1-STABLE machine. I don't even have to click anything (I don't even get the chance to do so). 100.0,2 runs fine.
Comment 2 Jack 2022-05-07 03:48:49 UTC
Same this is happening on 13.1-STABLE FreeBSD 13.1-STABLE #0 stable/13-n250673-84849cfd1dc0: Wed May  4 00:37:21 PDT 2022 firefox-100.0_3,2
Comment 3 Jack 2022-05-07 03:50:22 UTC
(In reply to Jack from comment #2)
Same thing as in crashes on first startup. On next startup it will say firefox crashed on last start, refresh firefox or open, both result in crashing.
Comment 4 Jürgen Weber 2022-05-07 07:22:24 UTC
There was just a new update
firefox: 100.0_1,2 -> 100.0_3,2

Firefox is working fine again. Thanks.
Comment 5 Jack 2022-05-07 07:35:50 UTC
100.0_3,2 is the version I have installed and is the one that is still crashing.
Comment 6 Graham Perrin 2022-05-14 04:06:20 UTC
(In reply to Joel Bodenmann from comment #1)
(In reply to Jack from comment #5)

Suggestion: continue under <https://forums.freebsd.org/posts/566959>
Comment 7 Jack 2022-05-14 09:11:51 UTC
I recompiled without LTO and it stopped crashing but with LTO enabled, it crashes on startup
Comment 8 Joel Bodenmann 2022-05-14 13:16:47 UTC
I am not sure whether this is the same problem or not. I recompiled with LTO disabled and from a user perspective, the browser behaves as intended again. I don't get any crash anymore.
However, as initially stated, the crash I got was pretty much immediately. I did not have to click anything. I never go tot the web browser window itself.
Comment 9 Jack 2022-05-14 13:51:10 UTC
(In reply to Joel Bodenmann from comment #8)
sounds identical to my experience