Bug 263873 - FreeBSD-13.0-RELEASE boot failure on Raspberry Pi 2B Rev 1.1
Summary: FreeBSD-13.0-RELEASE boot failure on Raspberry Pi 2B Rev 1.1
Status: Closed Not A Bug
Alias: None
Product: Base System
Classification: Unclassified
Component: arm (show other bugs)
Version: 13.0-RELEASE
Hardware: arm Any
: --- Affects Many People
Assignee: freebsd-arm (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-05-09 09:15 UTC by Greg Quinlan
Modified: 2022-05-09 09:34 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Greg Quinlan 2022-05-09 09:15:54 UTC
Hi,

I have tried to use a FreeBSD-13.0-RELEASE memory card image on my RPI2B but I get the dreaded rainbow screen. (Also tried 13.1-RC6 same result)

I have use the following command to create the memory card;

 dd if=FreeBSD-13.0-arm-armv6-RPI-B.img of=/dev/da0 bs=1m conv=sync

The image writes without issue but when placed in the RPI2B it will not boot.

The two file systems are moutable using a memory card reader and plugging that into another FreeBSD machine;

 mkdir /msdos
 mount -t msdosfs /dev/da0s1 /msdos
 mount /dev/da0s2a /mnt

I have also tried FreeBSD-12.3-RELEASE image using the same dd command and the RPI2B boots just fine. i.e. works as intended.

The power supply is a good quality one with an output of 3.1 amps.

Thanks

Greg
Comment 1 Emmanuel Vadot freebsd_committer 2022-05-09 09:20:05 UTC
RPI-B is only for the first revision of the Pi and the Pi0.
For RPI2 use FreeBSD-13.0-RELEASE-arm-armv7-GENERICSD.img.

Cheers,
Comment 2 Greg Quinlan 2022-05-09 09:34:11 UTC
Thanks Emmanuel. I was just in the process I trying this.