Bug 263883 - Possible issue with a .gitignore rule
Summary: Possible issue with a .gitignore rule
Status: Closed Not A Bug
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: Nuno Teixeira
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-05-09 16:40 UTC by John Mehr
Modified: 2022-05-20 08:05 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (eduardo)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description John Mehr 2022-05-09 16:40:21 UTC
Hello,

I've been adding .gitignore support to net/gitup and in working with the ports tree, it looks like there might be an issue with the one of the rules in its .gitignore.  I might be wrong, but it looks like

/java/eclipse/files/patch-eclipse.platform.swt

is being inadvertently ignored by a rule committed in 2015 (eaee7c7cc941451682e9e884729cf1e23f955b17) to ignore vim swapfiles:

*.sw[p-z]

Can you please confirm?  Thanks!
Comment 1 Nuno Teixeira freebsd_committer 2022-05-10 08:11:40 UTC
Hello John,

Sorry but I can't confirm that because I don't understand what you asking me.
Comment 2 John Mehr 2022-05-19 16:02:03 UTC
Sorry.  I misunderstood how .gitignore rules work and there is no problem with the rules in the ports repository's .gitingore file.  This bug can be closed and I apologize for the extra work it created for you.  Thanks!
Comment 3 Nuno Teixeira freebsd_committer 2022-05-20 08:05:49 UTC
Cheers!