Bug 263903 - textproc/hs-pandoc unfetchable source unliftio-core-0.2.0.1/unliftio-core-0.2.0.1.tar.gz
Summary: textproc/hs-pandoc unfetchable source unliftio-core-0.2.0.1/unliftio-core-0....
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-haskell (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-05-10 22:07 UTC by alt2600
Modified: 2022-05-11 07:42 UTC (History)
2 users (show)

See Also:
arrowd: maintainer-feedback+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description alt2600 2022-05-10 22:07:24 UTC
===>  License GPLv2 accepted by the user
===>   hs-pandoc-2.14.2_1 depends on file: /usr/local/sbin/pkg - found
=> unliftio-core-0.2.0.1/unliftio-core-0.2.0.1.tar.gz doesn't seem to exist in /usr/ports/distfiles//cabal.
=> Attempting to fetch https://hackage.haskell.org/package/unliftio-core-0.2.0.1/unliftio-core-0.2.0.1.tar.gz
fetch: unliftio-core-0.2.0.1/unliftio-core-0.2.0.1.tar.gz is not a directory
=> Attempting to fetch http://hackage.haskell.org/package/unliftio-core-0.2.0.1/unliftio-core-0.2.0.1.tar.gz
fetch: unliftio-core-0.2.0.1/unliftio-core-0.2.0.1.tar.gz is not a directory
=> Attempting to fetch http://distcache.FreeBSD.org/ports-distfiles/cabal/unliftio-core-0.2.0.1/unliftio-core-0.2.0.1.tar.gz
fetch: unliftio-core-0.2.0.1/unliftio-core-0.2.0.1.tar.gz is not a directory
=> Couldn't fetch it - please try to retrieve this
=> port manually into /usr/ports/distfiles//cabal and try again.
*** Error code 1

Stop.
make: stopped in /usr/ports/textproc/hs-pandoc

===>>> make build failed for textproc/hs-pandoc
===>>> Aborting update


===>>> You can restart from the point of failure with this command line:
       portmaster <flags> textproc/hs-pandoc 

everything ahead fetches, this piece does not, nor sure what happens beyond this source file. After the last bump to devel/libffi . I'm not sure why this file is seemingly missing as there doesn't seem to be too many updates except for these port bumps due to dependencies updating. Last time I had to build this port was November 2021. The only difference between this source and the ones that  download fine was this one is being defaulted to distcache server while all the others come from haskell.org's servers. I can confirm manually clicking the distcache link would allow downloading, but something about referencing directories doesn't seem to be liked with distcache where haskell doesn't mind it.
Comment 1 Kelly Hays 2022-05-11 05:08:48 UTC
I have the same issue. Below is the tail of poudriere build log:

=> Attempting to fetch https://hackage.haskell.org/package/unix-compat-0.5.3/unix-compat-0.5.3.tar.gz
fetch: https://hackage.haskell.org/package/unix-compat-0.5.3/unix-compat-0.5.3.tar.gz: size unknown
fetch: https://hackage.haskell.org/package/unix-compat-0.5.3/unix-compat-0.5.3.tar.gz: size of remote file is not known
unix-compat-0.5.3/unix-compat-0.5.3.tar.gz              13 kB 8955 kBps    00s
=> unliftio-core-0.2.0.1/unliftio-core-0.2.0.1.tar.gz doesn't seem to exist in /portdistfiles/cabal.
=> Attempting to fetch https://hackage.haskell.org/package/unliftio-core-0.2.0.1/unliftio-core-0.2.0.1.tar.gz
fetch: unliftio-core-0.2.0.1/unliftio-core-0.2.0.1.tar.gz is not a directory
=> Attempting to fetch http://hackage.haskell.org/package/unliftio-core-0.2.0.1/unliftio-core-0.2.0.1.tar.gz
fetch: unliftio-core-0.2.0.1/unliftio-core-0.2.0.1.tar.gz is not a directory
=> Attempting to fetch http://distcache.FreeBSD.org/ports-distfiles/cabal/unliftio-core-0.2.0.1/unliftio-core-0.2.0.1.tar.gz
fetch: unliftio-core-0.2.0.1/unliftio-core-0.2.0.1.tar.gz is not a directory
=> Couldn't fetch it - please try to retrieve this
=> port manually into /portdistfiles/cabal and try again.
*** Error code 1

Stop.
make: stopped in /usr/ports/textproc/hs-pandoc
=>> Cleaning up wrkdir
===>  Cleaning for hs-pandoc-2.14.2_1
build of textproc/hs-pandoc | hs-pandoc-2.14.2_1 ended at Wed May 11 00:02:36 CDT 2022
build time: 00:00:38
!!! build failure encountered !!!
Comment 2 commit-hook freebsd_committer 2022-05-11 07:40:56 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=7e5d181c77aea7f32df4f1c97d4b6fd55d52fe75

commit 7e5d181c77aea7f32df4f1c97d4b6fd55d52fe75
Author:     Gleb Popov <arrowd@FreeBSD.org>
AuthorDate: 2022-05-11 07:38:45 +0000
Commit:     Gleb Popov <arrowd@FreeBSD.org>
CommitDate: 2022-05-11 07:40:04 +0000

    textproc/hs-pandoc: Fix fetching.

    The same package (unlift-core) was listed twice with different revisions.

    PR:             263903

 textproc/hs-pandoc/Makefile | 2 +-
 textproc/hs-pandoc/distinfo | 6 +-----
 2 files changed, 2 insertions(+), 6 deletions(-)
Comment 3 commit-hook freebsd_committer 2022-05-11 07:41:58 UTC
A commit in branch 2022Q2 references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=9ce3131c0074c7832c8e3c3db0d58ec0a0a3ffd4

commit 9ce3131c0074c7832c8e3c3db0d58ec0a0a3ffd4
Author:     Gleb Popov <arrowd@FreeBSD.org>
AuthorDate: 2022-05-11 07:38:45 +0000
Commit:     Gleb Popov <arrowd@FreeBSD.org>
CommitDate: 2022-05-11 07:41:04 +0000

    textproc/hs-pandoc: Fix fetching.

    The same package (unlift-core) was listed twice with different revisions.

    PR:             263903
    (cherry picked from commit 7e5d181c77aea7f32df4f1c97d4b6fd55d52fe75)

 textproc/hs-pandoc/Makefile | 2 +-
 textproc/hs-pandoc/distinfo | 6 +-----
 2 files changed, 2 insertions(+), 6 deletions(-)
Comment 4 Gleb Popov freebsd_committer 2022-05-11 07:42:02 UTC
Thanks for the report, it was my bad.