Bug 263932 - sysutils/py-ansible-lint: @py38 6.1.0 fails to run - No module named 'jsonschema'
Summary: sysutils/py-ansible-lint: @py38 6.1.0 fails to run - No module named 'jsonsch...
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Matthew Seaman
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-05-12 08:00 UTC by Andre Rikkert de Koe - ARK-ICT
Modified: 2022-05-12 20:10 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (matthew)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andre Rikkert de Koe - ARK-ICT 2022-05-12 08:00:08 UTC
##
## ansible-lint 6.1.0 needs py-jsonschema as run dependency
##

root@freebsd13:~ # date
Thu May 12 09:57:12 CEST 2022
root@freebsd13:~ # ansible-lint --version
ansible-lint 6.1.0 using ansible 2.12.4
root@freebsd13:~ # ansible-lint 
Traceback (most recent call last):
  File "/usr/local/bin/ansible-lint", line 33, in <module>
    sys.exit(load_entry_point('ansible-lint==6.1.0', 'console_scripts', 'ansible-lint')())
  File "/usr/local/lib/python3.8/site-packages/ansiblelint/__main__.py", line 252, in _run_cli_entrypoint
    sys.exit(main(sys.argv))
  File "/usr/local/lib/python3.8/site-packages/ansiblelint/__main__.py", line 170, in main
    rules = RulesCollection(options.rulesdirs)
  File "/usr/local/lib/python3.8/site-packages/ansiblelint/rules/__init__.py", line 341, in __init__
    for rule in load_plugins(rulesdir):
  File "/usr/local/lib/python3.8/site-packages/ansiblelint/rules/__init__.py", line 308, in load_plugins
    spec.loader.exec_module(module)
  File "<frozen importlib._bootstrap_external>", line 843, in exec_module
  File "<frozen importlib._bootstrap>", line 219, in _call_with_frames_removed
  File "/usr/local/lib/python3.8/site-packages/ansiblelint/rules/schema.py", line 10, in <module>
    from jsonschema import validate
ModuleNotFoundError: No module named 'jsonschema'
root@freebsd13:~ # 

##
## fixed after installing dependency
##

...
====> Compressing man pages (compress-man)
===>  Installing for py38-jsonschema-4.5.1
===>  Checking if py38-jsonschema is already installed
===>   Registering installation for py38-jsonschema-4.5.1
Installing py38-jsonschema-4.5.1...
root@freebsd13:/usr/ports/devel/py-jsonschema # ansible-lint --version
ansible-lint 6.1.0 using ansible 2.12.4
root@freebsd13:/usr/ports/devel/py-jsonschema # ansible-lint
root@freebsd13:/usr/ports/devel/py-jsonschema #
Comment 1 Matthew Seaman freebsd_committer 2022-05-12 11:09:45 UTC
Apologies.  I missed the dependency change in the latest update.  I shall fix this tonight.
Comment 2 commit-hook freebsd_committer 2022-05-12 20:04:55 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=08c2e911e9beeb640b9cf8acbc0bb2f1781add84

commit 08c2e911e9beeb640b9cf8acbc0bb2f1781add84
Author:     Matthew Seaman <matthew@FreeBSD.org>
AuthorDate: 2022-05-12 20:01:17 +0000
Commit:     Matthew Seaman <matthew@FreeBSD.org>
CommitDate: 2022-05-12 20:03:50 +0000

    sysutils/py-ansible-lint: add missing dependency on py-jsonschema

    PR:             263932
    Reported by:     Andre Rikkert de Koe

 sysutils/py-ansible-lint/Makefile | 2 ++
 1 file changed, 2 insertions(+)
Comment 3 Matthew Seaman freebsd_committer 2022-05-12 20:10:19 UTC
Fix committed, thanks!