Bug 263957 - graphics/gdk-pixbuf2 error
Summary: graphics/gdk-pixbuf2 error
Status: New
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Only Me
Assignee: freebsd-desktop (Team)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-05-13 18:25 UTC by gja822
Modified: 2022-05-22 18:50 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (desktop)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description gja822 2022-05-13 18:25:28 UTC
On the FreeBSD forum I've posted some details: https://forums.freebsd.org/threads/gdk-pixbuf2-problem.85118/

During upgrade of graphics/gdk-pixbuf2 it leaves gdk-pixbuf-query-lo.core file in /usr/ports/graphics/gdk-pixbuf2 directory on install stage (not in work subdirectory).
But then it states that port's upgrade is successful.

But after that x11-toolkits/gtk20 fails to upgrade:

/usr/local/bin/gdk-pixbuf-csource --raw --build-list        \
        apple_red  ./apple-red.png    \
                gnome_foot ./gnome-foot.png    \
        > test-inline-pixbufs.h              \
|| (rm -f test-inline-pixbufs.h && false)
failed to load "./apple-red.png": Couldn't recognize the image file format for file "./apple-red.png"
gmake[4]: *** [Makefile:1044: test-inline-pixbufs.h] Error 1


So, I suppose, gdk-pixbuf2 do not work properly.

I've tried to upgrade all dependencies of gdk-pixbuf2, but without luck. So, now I have no working MATE.

I'm on FreeBSD 12-STABLE.
Comment 1 gja822 2022-05-22 18:50:39 UTC
Well, as can see, the problem may reside not in gdk-pixbuf2 itself, since its source was not upgraded for a while, was it?
But also I've rebuilt all ports' dependencies, without luck. Also tried with different compiler (clang12). May be some change in infrastructure. Hard to trace the problem for me.
But I've left without Gnome2 (MATE exactly) graphical environment for now.