Bug 264124 - [NEW PORT] mail/claws-mail-keyword_warner - plugin for Claws Mail
Summary: [NEW PORT] mail/claws-mail-keyword_warner - plugin for Claws Mail
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Juraj Lutter
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-05-21 12:04 UTC by bsd
Modified: 2022-05-31 14:02 UTC (History)
3 users (show)

See Also:
portmaster: maintainer-feedback+


Attachments
diff to add mail/claws-mail-keyword_warner port (815 bytes, patch)
2022-05-21 12:04 UTC, bsd
no flags Details | Diff
diff to add mail/claws-mail-keyword_warner port (fixed) (1.18 KB, patch)
2022-05-23 10:44 UTC, bsd
bsd: maintainer-approval?
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description bsd 2022-05-21 12:04:10 UTC
Created attachment 234079 [details]
diff to add mail/claws-mail-keyword_warner port

This port adds Keyword Warner plugin for Claws Mail which shows warning when sending mail containing some configurable keyword.

Plugin builds without errors, loads into Claws Mail.
Comment 1 bsd 2022-05-23 10:44:59 UTC
Created attachment 234148 [details]
diff to add mail/claws-mail-keyword_warner port (fixed)

diff to add mail/claws-mail-keyword_warner port

Patch to mail/Makefile included
Comment 2 Chris Hutchinson 2022-05-25 18:31:41 UTC
(In reply to bsd from comment #1)
Thanks for all your time and effort Milan! :-)
But, it complains fairly loudly:

Warning: you need USES=ssl
Error: /usr/local/lib/claws-mail/plugins/keyword_warner.so is linked to /usr/local/lib/libgtk-x11-2.0.so.0 from x11-toolkits/gtk20 but it is not declared as a dependency
Warning: you need USE_GNOME+=gtk20
Error: /usr/local/lib/claws-mail/plugins/keyword_warner.so is linked to /usr/local/lib/libgdk-x11-2.0.so.0 from x11-toolkits/gtk20 but it is not declared as a dependency
Warning: you need USE_GNOME+=gtk20
Error: /usr/local/lib/claws-mail/plugins/keyword_warner.so is linked to /usr/local/lib/libpangocairo-1.0.so.0 from x11-toolkits/pango but it is not declared as a dependency
Warning: you need USE_GNOME+=pango
Error: /usr/local/lib/claws-mail/plugins/keyword_warner.so is linked to /usr/local/lib/libatk-1.0.so.0 from accessibility/atk but it is not declared as a dependency
Warning: you need USE_GNOME+=atk
Error: /usr/local/lib/claws-mail/plugins/keyword_warner.so is linked to /usr/local/lib/libcairo.so.2 from graphics/cairo but it is not declared as a dependency
Warning: you need USE_GNOME+=cairo
Error: /usr/local/lib/claws-mail/plugins/keyword_warner.so is linked to /usr/local/lib/libgdk_pixbuf-2.0.so.0 from graphics/gdk-pixbuf2 but it is not declared as a dependency
Warning: you need USE_GNOME+=gdkpixbuf2
Error: /usr/local/lib/claws-mail/plugins/keyword_warner.so is linked to /usr/local/lib/libgio-2.0.so.0 from devel/glib20 but it is not declared as a dependency
Warning: you need USE_GNOME+=glib20
Error: /usr/local/lib/claws-mail/plugins/keyword_warner.so is linked to /usr/local/lib/libpangoft2-1.0.so.0 from x11-toolkits/pango but it is not declared as a dependency
Warning: you need USE_GNOME+=pango
Error: /usr/local/lib/claws-mail/plugins/keyword_warner.so is linked to /usr/local/lib/libpango-1.0.so.0 from x11-toolkits/pango but it is not declared as a dependency
Warning: you need USE_GNOME+=pango
Error: /usr/local/lib/claws-mail/plugins/keyword_warner.so is linked to /usr/local/lib/libgobject-2.0.so.0 from devel/glib20 but it is not declared as a dependency
Warning: you need USE_GNOME+=glib20
Error: /usr/local/lib/claws-mail/plugins/keyword_warner.so is linked to /usr/local/lib/libglib-2.0.so.0 from devel/glib20 but it is not declared as a dependency
Warning: you need USE_GNOME+=glib20
Error: /usr/local/lib/claws-mail/plugins/keyword_warner.so is linked to /usr/local/lib/libintl.so.8 from devel/gettext-runtime but it is not declared as a dependency
Warning: you need USES+=gettext-runtime
Error: /usr/local/lib/claws-mail/plugins/keyword_warner.so is linked to /usr/local/lib/libharfbuzz.so.0 from print/harfbuzz but it is not declared as a dependency
Warning: you need LIB_DEPENDS+=libharfbuzz.so:print/harfbuzz
Error: /usr/local/lib/claws-mail/plugins/keyword_warner.so is linked to /usr/local/lib/libfontconfig.so.1 from x11-fonts/fontconfig but it is not declared as a dependency
Warning: you need LIB_DEPENDS+=libfontconfig.so:x11-fonts/fontconfig
Error: /usr/local/lib/claws-mail/plugins/keyword_warner.so is linked to /usr/local/lib/libfreetype.so.6 from print/freetype2 but it is not declared as a dependency
Warning: you need LIB_DEPENDS+=libfreetype.so:print/freetype2
Error: /usr/local/lib/claws-mail/plugins/keyword_warner.so is linked to /usr/local/lib/libetpan.so.20 from mail/libetpan but it is not declared as a dependency
Warning: you need LIB_DEPENDS+=libetpan.so:mail/libetpan
Error: /usr/local/lib/claws-mail/plugins/keyword_warner.so is linked to /usr/local/lib/libcurl.so.4 from ftp/curl but it is not declared as a dependency
Warning: you need LIB_DEPENDS+=libcurl.so:ftp/curl
Error: /usr/local/lib/claws-mail/plugins/keyword_warner.so is linked to /usr/local/lib/libexpat.so.1 from textproc/expat2 but it is not declared as a dependency
Warning: you need LIB_DEPENDS+=libexpat.so:textproc/expat2
Error: /usr/local/lib/claws-mail/plugins/keyword_warner.so is linked to /usr/local/lib/libsasl2.so.3 from security/cyrus-sasl2 but it is not declared as a dependency
Warning: you need LIB_DEPENDS+=libsasl2.so:security/cyrus-sasl2
Error: /usr/local/lib/claws-mail/plugins/keyword_warner.so is linked to /usr/local/lib/libssl.so.11 from security/openssl but it is not declared as a dependency
Warning: you need USES=ssl
Error: /usr/local/lib/claws-mail/plugins/keyword_warner.so is linked to /usr/local/lib/libcrypto.so.11 from security/openssl but it is not declared as a dependency
Warning: you need USES=ssl

Adding:
LIB_DEPENDS+=	libharfbuzz.so:print/harfbuzz \
		libfontconfig.so:x11-fonts/fontconfig \
		libfreetype.so:print/freetype2 \
		libetpan.so:mail/libetpan \
		libcurl.so:ftp/curl \
		libexpat.so:textproc/expat2 \
		libsasl2.so:security/cyrus-sasl2

USES=		ssl gettext-runtime
USE_GNOME+=	gtk20 pango atk cairo gdkpixbuf2 glib20 \
		pango glib20

Silences every WARN but those concerning GNOME.
I won't have time to further pursue this for awhile. Maybe you
have the time? :-)

Thanks again.

Chris
Comment 3 bsd 2022-05-25 19:15:45 UTC
(In reply to Chris Hutchinson from comment #2)

All the slave Claws Mail ports behave the same. I think stage-qa does not take this into account - it is not a self containing port, it could be used only when main Claws Mail port is installed, and main port satisfies all those needs.

Maybe someone else with more experience could chime in, but I think in case of slave port like this, all errors reported are actually bogus, because all livraries mentioned are already installed. Trying to fix it explicitly means adding tons of extra lines (OK, tons are slightly exaggerated) with no added benefit...
Comment 4 Chris Hutchinson 2022-05-26 00:29:46 UTC
(In reply to bsd from comment #3)
It was clear to me that the parent port
(Claws Mail) already satisfied all the
dependencies the slave complained about.
So as an experiment, I double checked.
The one (other) plugin I tested didn't
act this way.
I just now performed some more testing.
Nearly all of the other (Claws Mail)
plugins react the same way. This some how
seems wrong. But one will need the parent
(Claws Mail) for any of the plugins to be
of value. So as the parent port; Claws Mail
satisfies all the dependencies not already
named within a plugin. I'm going to sign off
on this.
IOW looks good.

Thanks!

Chris
Comment 5 Chris Hutchinson 2022-05-26 00:30:52 UTC
Comment on attachment 234148 [details]
diff to add mail/claws-mail-keyword_warner port (fixed)

LGTM, WGFM

Thanks Milan!

Chris
Comment 6 Chris Hutchinson 2022-05-26 00:32:37 UTC
Comment on attachment 234148 [details]
diff to add mail/claws-mail-keyword_warner port (fixed)

This time for sure. :-?
Comment 7 Chris Hutchinson 2022-05-26 00:33:55 UTC
I don't know whats wrong. But bugzilla won't let
me approve the diff/patch.
I guess I'll have to post one myself?
Comment 8 commit-hook freebsd_committer 2022-05-31 13:56:23 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=aad1aa28e6af9004bd9fb1f479db69f5ee7cc509

commit aad1aa28e6af9004bd9fb1f479db69f5ee7cc509
Author:     Milan Obuch <bsd@dino.sk>
AuthorDate: 2022-05-31 13:54:49 +0000
Commit:     Juraj Lutter <otis@FreeBSD.org>
CommitDate: 2022-05-31 13:55:57 +0000

    mail/claws-mail-keyword_warner: Add new port

    This port adds Keyword Warner plugin for Claws Mail which shows warning when
    sending mail containing some configurable keyword.

    Approved by:    Chris Hutchinson <portmaster@bsdforge.com> (maintainer)
    PR:             264124

 mail/Makefile                                  | 1 +
 mail/claws-mail-keyword_warner/Makefile (new)  | 8 ++++++++
 mail/claws-mail-keyword_warner/pkg-descr (new) | 4 ++++
 3 files changed, 13 insertions(+)
Comment 9 Juraj Lutter freebsd_committer 2022-05-31 14:02:17 UTC
Committed, thanks.