Bug 264776 - devel/meson: update to 0.63.1
Summary: devel/meson: update to 0.63.1
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Jan Beich
URL: https://mesonbuild.com/Release-notes-...
Keywords: needs-qa, patch
Depends on:
Blocks:
 
Reported: 2022-06-19 21:19 UTC by Jan Beich
Modified: 2022-08-25 19:09 UTC (History)
2 users (show)

See Also:
tcberner: maintainer-feedback+
antoine: exp-run+


Attachments
v0 (RC1) (1.32 KB, patch)
2022-06-19 21:19 UTC, Jan Beich
no flags Details | Diff
v0.1 (RC2) (1.49 KB, patch)
2022-06-27 19:05 UTC, Jan Beich
no flags Details | Diff
v1 (0.63.0) (1.31 KB, patch)
2022-07-03 18:01 UTC, Jan Beich
no flags Details | Diff
v1.1 (0.63.1) (1.26 KB, patch)
2022-08-14 08:22 UTC, Jan Beich
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Beich freebsd_committer 2022-06-19 21:19:40 UTC
Created attachment 234798 [details]
v0 (RC1)

Previous dot-zero updates often had regressions, requiring to wait for a patch-level release. Let's try testing in advance.
Comment 1 Jan Beich freebsd_committer 2022-06-27 19:05:23 UTC
Created attachment 234974 [details]
v0.1 (RC2)
Comment 3 Jan Beich freebsd_committer 2022-07-03 18:01:56 UTC
Created attachment 235056 [details]
v1 (0.63.0)
Comment 4 Tobias C. Berner freebsd_committer 2022-07-04 06:28:23 UTC
lgtm after the exp-run.
Comment 6 Jan Beich freebsd_committer 2022-08-14 08:22:04 UTC
Created attachment 235897 [details]
v1.1 (0.63.1)

Can you re-try? I can't reproduce exp-run fallout in comment 5.
Comment 8 commit-hook freebsd_committer 2022-08-17 19:16:56 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=fc3fe5b9986b630e9d46f132c6dea611f547f97c

commit fc3fe5b9986b630e9d46f132c6dea611f547f97c
Author:     Jan Beich <jbeich@FreeBSD.org>
AuthorDate: 2022-08-17 19:12:55 +0000
Commit:     Jan Beich <jbeich@FreeBSD.org>
CommitDate: 2022-08-17 19:14:52 +0000

    x11/tilix: disable SSP unsupported by lang/ldc

    meson.build:1:0: ERROR: Unable to detect linker for compiler `ldc2 -L=--version /tmp/tmpo84ihqx4.d -fstack-protector-strong`
    stdout:
    stderr: ldc2: Unknown command line argument '-fstack-protector-strong'.  Try: 'ldc2 --help'
    ldc2: Did you mean '--stack-symbol-ordering'?

    PR:             264776
    Reported by:    antoine (via exp-run)
    Regressed by:   https://github.com/mesonbuild/meson/commit/235c78682e82

 x11/tilix/Makefile | 1 +
 1 file changed, 1 insertion(+)
Comment 9 Jan Beich freebsd_committer 2022-08-25 17:10:14 UTC
What happened to exp-run here? I don't have anything left to fix.
Comment 10 Antoine Brodin freebsd_committer 2022-08-25 18:44:26 UTC
tilix is a leaf port so it should be fine
Comment 11 Jan Beich freebsd_committer 2022-08-25 18:50:23 UTC
comment 4 only granted approval on the condition an exp-run has passed. Since you didn't toggle exp-run bug flag and didn't change/reset Assignee I'm not sure if there's something else left to wait for.
Comment 12 commit-hook freebsd_committer 2022-08-25 19:09:17 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=bb1493b0747cda236fd002900baae5764aa1527d

commit bb1493b0747cda236fd002900baae5764aa1527d
Author:     Jan Beich <jbeich@FreeBSD.org>
AuthorDate: 2022-06-19 19:24:53 +0000
Commit:     Jan Beich <jbeich@FreeBSD.org>
CommitDate: 2022-08-25 19:08:30 +0000

    devel/meson: update to 0.63.1

    Changes:        https://mesonbuild.com/Release-notes-for-0-63-0.html
    PR:             264776
    Reported by:    GitHub (watch releases)
    Exp-run by:     antoine
    Approved by:    tcberner

 devel/meson/Makefile | 2 +-
 devel/meson/distinfo | 6 +++---
 2 files changed, 4 insertions(+), 4 deletions(-)