Bug 269141 - archivers/quazip doesn't build with qt6 core installed, cannot disable as is considered required package
Summary: archivers/quazip doesn't build with qt6 core installed, cannot disable as is ...
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-kde (Team)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2023-01-24 23:23 UTC by alt2600
Modified: 2023-01-26 01:17 UTC (History)
1 user (show)

See Also:
tcberner: maintainer-feedback+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description alt2600 2023-01-24 23:23:49 UTC
===>  Configuring for quazip-qt5-1.4
===>  Performing out-of-source build
/bin/mkdir -p /usr/ports/archivers/quazip/work/.build
-- The C compiler identification is Clang 13.0.0
-- The CXX compiler identification is Clang 13.0.0
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Check for working C compiler: /usr/bin/cc - skipped
-- Detecting C compile features
-- Detecting C compile features - done
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Check for working CXX compiler: /usr/bin/c++ - skipped
-- Detecting CXX compile features
-- Detecting CXX compile features - done
-- Found Threads: TRUE  
-- Performing Test HAVE_STDATOMIC
-- Performing Test HAVE_STDATOMIC - Success
-- Found WrapAtomic: TRUE  
-- Could NOT find Qt6Core5Compat (missing: Qt6Core5Compat_DIR)
CMake Error at CMakeLists.txt:75 (find_package):
  Found package configuration file:

    /usr/local/lib/cmake/Qt6/Qt6Config.cmake

  but it set Qt6_FOUND to FALSE so package "Qt6" is considered to be NOT
  FOUND.  Reason given by package:

  Failed to find required Qt component "Core5Compat".

  Expected Config file at
  "/usr/local/lib/cmake/Qt6Core5Compat/Qt6Core5CompatConfig.cmake" does NOT
  exist

  

  Configuring with --debug-find-pkg=Qt6Core5Compat might reveal details why
  the package was not found.

  Configuring with -DQT_DEBUG_FIND_PACKAGE=ON will print the values of some
  of the path variables that find_package uses to try and find the package.



-- Configuring incomplete, errors occurred!
See also "/usr/ports/archivers/quazip/work/.build/CMakeFiles/CMakeOutput.log".
See also "/usr/ports/archivers/quazip/work/.build/CMakeFiles/CMakeError.log".
*** Error code 1

Stop.
make: stopped in /usr/ports/archivers/quazip



adding to Makefile
CMAKE_ON+=	CMAKE_DISABLE_FIND_PACKAGE_Qt6

yields

CMake Error at CMakeLists.txt:75 (find_package):
  find_package for module Qt6 called with REQUIRED, but
  CMAKE_DISABLE_FIND_PACKAGE_Qt6 is enabled.  A REQUIRED package cannot be
  disabled.


-- Using Qt version 6
-- Found ZLIB: /usr/lib/libz.so (found version "1.2.12") 
-- Using BZIP2 1.0.8
-- Found BZip2: /usr/lib/libbz2.so (found version "1.0.8") 
-- Configuring incomplete, errors occurred!
See also "/usr/ports/archivers/quazip/work/.build/CMakeFiles/CMakeOutput.log".
See also "/usr/ports/archivers/quazip/work/.build/CMakeFiles/CMakeError.log".
*** Error code 1

appears updated version might requires QT6? Makefile is still adding QT5 suffix and uses qt:5
Comment 1 Tobias C. Berner freebsd_committer 2023-01-25 05:29:07 UTC
(In reply to alt2600 from comment #0)
I'll add a qt6 flavor shortly.
Comment 2 Tobias C. Berner freebsd_committer 2023-01-25 06:23:15 UTC
This should now be fixed with 9ab8ec61c30dc799a69d1b57ea625e445a18d737 .

Please reopen if you still have issues after that :)


mfg Toibas
Comment 3 alt2600 2023-01-26 01:17:21 UTC
(In reply to Tobias C. Berner from comment #2)

it works now, thank you