Bug 29403 - niceheaders problems with index, pdf bookmarks
Summary: niceheaders problems with index, pdf bookmarks
Status: Closed FIXED
Alias: None
Product: Documentation
Classification: Unclassified
Component: Documentation (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Murray Stokely
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2001-08-03 02:50 UTC by Peter Johnson
Modified: 2001-09-02 03:39 UTC (History)
0 users

See Also:


Attachments
file.diff (851 bytes, patch)
2001-08-03 02:50 UTC, Peter Johnson
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Johnson 2001-08-03 02:50:01 UTC
The new niceheaders feature in doc/en_US.ISO8859-1/share/sgml/freebsd.dsl has a few minor problems: the new rule generation is incorrect for index generation (as the rule overwrites the second column of the first index page), and if you try to generate a PDF with bookmarks, an extra bookmark is added for every chapter, the index, and the glossary (the bookmark is blank for the index and glossary and "Chapter X" for chapters).

One caveat: I haven't tried reproducing these problems with the handbook, but I've noticed them in my own documentation project that I'm using the FreeBSD stylesheets for.

Fix: apply the following patch to /doc/en_US.ISO8859-1/share/sgml/freebsd.dsl:
(the first section fixes the PDF bookmarks problem, the second fixes the niceheaders/index problem:
How-To-Repeat: 1) Use NICE_HEADERS and GEN_INDEX together.
2) Generate PDF with bookmarks support.
Comment 1 Murray Stokely freebsd_committer 2001-08-03 20:12:14 UTC
State Changed
From-To: open->feedback

Your fix for the rule problem on the Index has been committed, thanks! 



Comment 2 Murray Stokely freebsd_committer 2001-08-03 20:12:14 UTC
Responsible Changed
From-To: freebsd-doc->murray

I'm working with the NICE_HEADERS stuff.
Comment 3 nik freebsd_committer 2001-08-03 21:52:47 UTC
On Thu, Aug 02, 2001 at 06:48:38PM -0700, Peter Johnson wrote:
> +      (make rule
> +	length: 475pt
> +	display-alignment: 'start
> +	space-before: (* (HSIZE 5) %head-before-factor%)
> +	line-thickness: 0.5pt))))


"length" should probably be calculated as a function of the page width,
and the left and right margins.

N
-- 
FreeBSD: The Power to Serve             http://www.freebsd.org/
FreeBSD Documentation Project           http://www.freebsd.org/docproj/

          --- 15B8 3FFC DDB4 34B0 AA5F  94B7 93A8 0764 2C37 E375 ---
Comment 4 Murray Stokely freebsd_committer 2001-09-02 03:38:01 UTC
State Changed
From-To: feedback->closed

The width of the rule is now based on body-width which is based on the 
page-width.  The rule is turned off for the index since that uses a 2 
column page sequence.  Thanks!