Bug 30421 - (I18N)Open Motif causes Segmentation Fault in some rare condition.
Summary: (I18N)Open Motif causes Segmentation Fault in some rare condition.
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Steve Price
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2001-09-07 20:30 UTC by Fuyuhiko Maruyama
Modified: 2002-07-26 05:10 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Fuyuhiko Maruyama 2001-09-07 20:30:00 UTC
This is a I18N (especially XIM handling) related problem and may not
appear for languages not need XIM server to input text.

Open Motif has it's own codes of XIM handling for widget which allow
user to input text.  For languages which need special handling of XIM server, e.g. Chinese, Japanese and Korean, Open Motif works quite well.
But there is some rare conditions which confuses Open Motif and let it
cause Segmentation Fault.  The widget currently focused is disposed is one such condition.

Fix: 

I made a patch for OpenMotif to fix the problem.
Placing the patch file into /usr/ports/open-motif/files fix the problem.
The patch file is at:
http://matsu-www.is.titech.ac.jp/~maruyama/patch-XmIm.c
How-To-Repeat: install /usr/ports/x11-toolkits/open-motif
then install /usr/ports/java/jdk13.
Installing /usr/ports/java/jdk13 directly isn't enough because jdk13 ports uses binary version of Motif (/usr/ports/x11-toolkits/open-motif-devel).

I think open-motif-devel also has the same problem but I'm not sure because I cannot debug jdk13 with binary version of Motif.

How to repeat the problem may not be easy for non CJK environment because it need to setup CJK environment.  So I don't write how to setup CJK env here.
To reproduce the problem on Japanese environment, it is simple.
$ setenv LANG ja_JP.EUC
$ kinput2 &
$ cd /usr/local/jdk1.3.1/demo/applets/ArcTest
$ ../../../bin/appletviewer example1.html
Comment 1 clefevre 2001-09-08 14:25:51 UTC
Fuyuhiko Maruyama wrote:
[snip]
> >Fix:
> I made a patch for OpenMotif to fix the problem.
> Placing the patch file into /usr/ports/open-motif/files fix the problem.
> The patch file is at:
> http://matsu-www.is.titech.ac.jp/~maruyama/patch-XmIm.c

how about submitting a bug report (/usr/X11R6/share/doc/openmotif/BUGREPORT)
to the Open Group ?

Cyrille.
-- 
Cyrille Lefevre                 mailto:clefevre@citeweb.net
Comment 2 Fuyuhiko Maruyama 2001-09-08 19:39:24 UTC
At Sat, 8 Sep 2001 15:25:51 +0200 (CEST),
Cyrille Lefevre wrote:
> 
> Fuyuhiko Maruyama wrote:
> [snip]
> > >Fix:
> > I made a patch for OpenMotif to fix the problem.
> > Placing the patch file into /usr/ports/open-motif/files fix the problem.
> > The patch file is at:
> > http://matsu-www.is.titech.ac.jp/~maruyama/patch-XmIm.c
> 
> how about submitting a bug report (/usr/X11R6/share/doc/openmotif/BUGREPORT)
> to the Open Group ?
> 
> Cyrille.
> -- 
> Cyrille Lefevre                 mailto:clefevre@citeweb.net

I've already reported that using Motifzone's bugzilla system, but I'm
not sure how quickly Open Group works.

--
Fuyuhiko MARUYAMA <fuyuhik8@is.titech.ac.jp>
Matsuoka laboratory,
Department of Mathematical and Computing Sciences,
Graduate School of Information Science and Engineering,
Tokyo Institute of Technology.
Comment 3 FUJISHIMA Satsuki freebsd_committer 2001-09-18 13:14:59 UTC
Responsible Changed
From-To: freebsd-ports->steve

Over to maintainer.
Comment 4 Fuyuhiko Maruyama 2002-02-09 19:44:16 UTC
Open Motif group send an email me to tell the problem I met is
resolved in their CVS.

I hope the next release(current release is Open Motif-2.2) of Open
Motif resolve our problem.

Thanks,
--
Fuyuhiko MARUYAMA <fuyuhik8@is.titech.ac.jp>
Comment 5 Greg Lewis freebsd_committer 2002-07-26 05:10:40 UTC
State Changed
From-To: open->closed

Committed, thanks!