Bug 34904 - graphics/imlib is not LOCALBASE clean
Summary: graphics/imlib is not LOCALBASE clean
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Ade Lovett
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2002-02-13 13:00 UTC by Kazutoshi Kubota
Modified: 2002-03-11 22:38 UTC (History)
0 users

See Also:


Attachments
file.diff (410 bytes, patch)
2002-02-13 13:00 UTC, Kazutoshi Kubota
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Kazutoshi Kubota 2002-02-13 13:00:01 UTC
The result of `imlib-config --libs` is missing, it's always -L/usr/local
with or without LOCALBASE such as /opt.

How-To-Repeat: env LOCALBASE=/opt (or other) make install.
Then run imlib-config --libs.
Comment 1 Pete Fritchman freebsd_committer 2002-02-13 15:41:41 UTC
Responsible Changed
From-To: freebsd-ports->gnome

Over to maintainer
Comment 2 Ade Lovett freebsd_committer 2002-03-11 06:14:28 UTC
Responsible Changed
From-To: gnome->ade

I'll look into this on my next upcoming build.
Comment 3 Ade Lovett freebsd_committer 2002-03-11 07:50:54 UTC
State Changed
From-To: open->feedback

Whilst your patch certainly removes one instance of a hardcoded /usr/local, 
it doesn't address the other, and I also see no issues with the PREFIX/lib 
being picked up first with imlib-config compile with a PREFIX set elsewhere. 

Please advise. 

guardian 13# /dist/build/bin/imlib-config --libs 
-L/dist/build/lib -lImlib -L/usr/local/lib -ltiff -lungif -lpng -lz -lm -lXext -L/usr/X11R6/lib -lSM -lICE -lXext -lX11 
guardian 14# /dist/build/bin/imlib-config --libs-gdk 
-L/dist/build/lib -lgdk_imlib -ltiff -lungif -lpng -lz -lm -L/usr/X11R6/lib -L/usr/X11R6/lib -lgtk12 -lgdk12 -L/usr/local/lib -Wl,-E -lgmodule12 -lglib12 -lintl -lXext -lX11 -lm -L/usr/local/lib
Comment 4 Ade Lovett freebsd_committer 2002-03-11 22:37:46 UTC
State Changed
From-To: feedback->closed

After some confusion on my part, patch committed, thanks!