Bug 35 - mount -t union -o -b : lower layer not seen by shell globbing and ls
Summary: mount -t union -o -b : lower layer not seen by shell globbing and ls
Status: Closed FIXED
Alias: None
Product: Base System
Classification: Unclassified
Component: kern (show other bugs)
Version: 2.0-RELEASE
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-bugs (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 1994-12-01 05:20 UTC by Wilhelm B. Kloke
Modified: 1998-04-12 17:51 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Wilhelm B. Kloke 1994-12-01 05:20:01 UTC
	Union mount -b does not work as expected.
	The file names accessible are seen neither to the shell globbing
	mechanism nor to ls.
	There seem to be other programs unable to find the files. (Just
	try to configure and make gnuplot.)

Fix: 

unknown
How-To-Repeat: 
	$ mkdir dreck
	$ /sbin/mount -t union -o -b gnuplot dreck
	$ ls
	$ ls header.mac
	header.mac
	$ ls *.mac
	ls: *.mac: No such file or directory
	$
Comment 1 Bruce Evans freebsd_committer 1995-03-25 14:06:38 UTC
State Changed
From-To: open->analyzed

The problem is known to be caused by readdir() not working for lkm'ed 
union file systems. 
Comment 2 pst freebsd_committer 1996-02-07 07:32:41 UTC
Responsible Changed
From-To: core->bde

Bruce wants to document in the FAQ that all union file system features should
be asssumed to be broken.  I'll leave this bug open and assigned to him
as a reminder.
Comment 3 Bruce Evans freebsd_committer 1996-12-17 12:05:18 UTC
Responsible Changed
From-To: bde->freebsd-bugs

I won't be fixing this soon. 
Comment 4 Poul-Henning Kamp freebsd_committer 1998-04-12 17:51:11 UTC
State Changed
From-To: analyzed->closed

unionfs doesn't work, we know it.