Bug 37265 - Maintainer update of devel/global to 4.4
Summary: Maintainer update of devel/global to 4.4
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Ade Lovett
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2002-04-20 01:40 UTC by Jos Backus
Modified: 2002-04-20 03:53 UTC (History)
0 users

See Also:


Attachments
file.diff (1.31 KB, patch)
2002-04-20 01:40 UTC, Jos Backus
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jos Backus 2002-04-20 01:40:01 UTC
    Update devel/global to version 4.4. This fixes a security vulnerability,
    and users are urged to upgrade asap:

    2002/3/30
       A security hole was found in the CGI program generated by htags(1).
       This security hole exists in the following version: 3.5, 3.51, 3.52,
       3.53, 3.54, 3.55, 4.0, 4.0.1, 4.1, 4.1.1, 4.2, 4.3, 4.3.1.  If you use
       above version and use the -f option of htags(1), please stop publishing
       hypertext generated by htags(1) and replace your GLOBAL with the fixed
       version 4.4. 

    Also update maintainer's e-mail address.
Comment 1 Ade Lovett freebsd_committer 2002-04-20 03:52:30 UTC
State Changed
From-To: open->closed

Patch committed - to everyone else, it jumped the queue because it 
was a security issue. 


Comment 2 Ade Lovett freebsd_committer 2002-04-20 03:52:30 UTC
Responsible Changed
From-To: freebsd-ports->ade

My fault[tm]