Bug 37523 - [i386] [patch] lock for bios16 call and vm86call
Summary: [i386] [patch] lock for bios16 call and vm86call
Status: Closed Overcome By Events
Alias: None
Product: Base System
Classification: Unclassified
Component: i386 (show other bugs)
Version: 5.0-CURRENT
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-i386 mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2002-04-28 10:40 UTC by davidx
Modified: 2019-01-25 18:51 UTC (History)
2 users (show)

See Also:


Attachments
file.diff (340 bytes, patch)
2002-04-28 10:40 UTC, davidx
no flags Details | Diff
file.diff (1.07 KB, patch)
2002-04-28 10:40 UTC, davidx
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description davidx 2002-04-28 10:40:01 UTC
	vm86 calling and bios16 calling are sharing same physical page vm86phystk as 
	their stack, while vm86 code was already locked down, the 16 bits protected mode 
        bios calling can still escape from vm86 lock, and bios service itself may also
	not reentranable.
Comment 1 Mark Linimon freebsd_committer freebsd_triage 2004-09-11 20:47:43 UTC
Responsible Changed
From-To: freebsd-bugs->davidxu

Submitter is now committer.
Comment 2 David Xu freebsd_committer 2014-04-14 09:16:13 UTC
Responsible Changed
From-To: davidxu->jhb

jhb@ may take a look.
Comment 3 Eitan Adler freebsd_committer freebsd_triage 2017-12-31 08:00:51 UTC
For bugs matching the following criteria:

Status: In Progress Changed: (is less than) 2014-06-01

Reset to default assignee and clear in-progress tags.

Mail being skipped
Comment 4 Oleksandr Tymoshenko freebsd_committer freebsd_triage 2019-01-24 06:44:14 UTC
David, is this PR still relevant?

Thanks
Comment 5 Oleksandr Tymoshenko freebsd_committer freebsd_triage 2019-01-25 18:51:32 UTC
David is not working on this patch and doesn't know whether it's still relevant. Closing as OBE. Feel free to reopen if you think the issue is still valid in recent version of FreeBSD