Bug 39826 - update-port: devel/stlport (compile BROKEN on latest 4-STABLE)
Summary: update-port: devel/stlport (compile BROKEN on latest 4-STABLE)
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-ports mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2002-06-25 05:50 UTC by Oliver Lehmann
Modified: 2002-06-26 20:05 UTC (History)
1 user (show)

See Also:


Attachments
file.diff (1.29 KB, patch)
2002-06-25 05:50 UTC, Oliver Lehmann
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Oliver Lehmann 2002-06-25 05:50:02 UTC
	stlport fails to compile on my 22th June STABLE

c++ -D_THREAD_SAFE -D_REENTRANT -Wall -g -O -I../../stlport -I.  -DEH_VECTOR_OPERATOR_NEW nc_alloc.cpp -c -o obj/nc_alloc.o
nc_alloc.cpp: In function `void * operator new(unsigned int)':
nc_alloc.cpp:229: declaration of `operator new(unsigned int)' throws different exceptions
/usr/include/g++/g++/new:28: previous declaration here
nc_alloc.cpp: In function `void operator delete(void *)':
nc_alloc.cpp:278: declaration of `operator delete(void *)' throws different exceptions
/usr/include/g++/g++/new:30: previous declaration here
gmake: *** [obj/nc_alloc.o] Error 1
*** Error code 2

Stop in /usr/ports/devel/stlport.
root@kartoffel stlport>

How-To-Repeat: 	update to latest stable
	cd /usr/ports/devel/stlport && make
Comment 1 Oliver Lehmann 2002-06-25 19:08:30 UTC
Hi again,

just FYI: the last commit doesn't fixed that problem.

  Greetings, Oliver


-- 
:======>   Oliver Lehmann   <======:     clear perl code  is better than
:====>  lehmann@ans-netz.de   <====:      unclear awk code; but NOTHING
:===>   http://www.pofo.de/    <===:    comes close to  unclear perl code
:=>   http://wishlist.pofo.de/   <=:     (taken from  comp.lang.awk FAQ)
Comment 2 pmarquis 2002-06-25 20:16:11 UTC
This is failing while doing a make test, which was added to the port=20
build without consulting me to demonstrate a bug in gcc.

The main library is built with g++, while the test program is built=20
with c++.  Can you verify that they're both pointing to the same=20
executable (which g++, which c++)?  Do you have any aliases that=20
might conflict?

The path to the new header file looks strange.  I get=20
/usr/include/g++/new, not /usr/include/g++/g++/new.  Do you have=20
multiple compilers installed?

--=20
Paul Marquis
pmarquis@pobox.com
Comment 3 Oliver Lehmann 2002-06-25 20:49:31 UTC
On Tue, 25 Jun 2002 15:16:11 -0400
Paul Marquis <pmarquis@pobox.com> wrote:

> The main library is built with g++, while the test program is built 
> with c++.  Can you verify that they're both pointing to the same 
> executable (which g++, which c++)?

it does

>  Do you have any aliases that 
> might conflict?

nope

> The path to the new header file looks strange.  I get 
> /usr/include/g++/new, not /usr/include/g++/g++/new.  Do you have 
> multiple compilers installed?

nope

olivleh1@kartoffel olivleh1> locate new | grep '/new$'
/usr/include/g++/new
/usr/local/include/stlport/new
olivleh1@kartoffel olivleh1> ls -l /usr/include/g++/g++
lrwxr-xr-x  1 root  wheel  16 Aug 21  2001 /usr/include/g++/g++ ->
/usr/include/g++
olivleh1@kartoffel olivleh1> which g++
/usr/bin/g++
olivleh1@kartoffel olivleh1> which c++
/usr/bin/c++
olivleh1@kartoffel olivleh1> ls -l /usr/bin/g++ /usr/bin/c++
-r-xr-xr-x  3 root  wheel  71376 Jun 23 01:43 /usr/bin/c++
-r-xr-xr-x  3 root  wheel  71376 Jun 23 01:43 /usr/bin/g++
olivleh1@kartoffel olivleh1> ls -l /usr/include/g++/new
-r--r--r--  1 root  wheel  1207 Nov 20  2000 /usr/include/g++/new
olivleh1@kartoffel olivleh1> c++ --version
2.95.4
olivleh1@kartoffel olivleh1> g++ --version
2.95.4
olivleh1@kartoffel olivleh1> md5 /usr/bin/c++
MD5 (/usr/bin/c++) = 6557d12f2ce53f51163b80659036c1ff
olivleh1@kartoffel olivleh1> md5 /usr/bin/g++
MD5 (/usr/bin/g++) = 6557d12f2ce53f51163b80659036c1ff
olivleh1@kartoffel olivleh1> 


Greetings, Oliver
-- 
:======>   Oliver Lehmann   <======:     clear perl code  is better than
:====>  lehmann@ans-netz.de   <====:      unclear awk code; but NOTHING
:===>   http://www.pofo.de/    <===:    comes close to  unclear perl code
:=>   http://wishlist.pofo.de/   <=:     (taken from  comp.lang.awk FAQ)
Comment 4 pmarquis 2002-06-26 04:11:34 UTC
Another person had reported this problem a while back on -current and=20
I couldn't reproduce it, as I don't run current.  We talked about=20
defining EH_DELETE_HAS_THROW_SPEC, but we didn't come to any=20
conclusions.  I just upgraded to 4-STABLE and finally got the error. =20
It appears gcc 2.95.4 is more pedantic about exceptions than in=20
previous versions.

I've verified that a slightly modified version of your patch works on=20
earlier versions of gcc, so I'm going to submit that.  Hopefully, it=20
won't break -current.

Eventually, I want to get rid of this portion of the port build, but=20
not before talking with the OpenOffice folks.

--=20
Paul Marquis
pmarquis@pobox.com
Comment 5 Ying-Chieh Liao freebsd_committer 2002-06-26 05:21:25 UTC
State Changed
From-To: open->patched

patch applied, plz cvsup and try it
Comment 6 Ying-Chieh Liao freebsd_committer 2002-06-26 20:04:48 UTC
State Changed
From-To: patched->closed

no longer a problem