Bug 40201 - Update port: databases/fastdb -> 2.41
Summary: Update port: databases/fastdb -> 2.41
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-ports mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2002-07-04 23:00 UTC by obraun
Modified: 2002-07-17 16:50 UTC (History)
0 users

See Also:


Attachments
file.diff (2.56 KB, patch)
2002-07-04 23:00 UTC, obraun
no flags Details | Diff
Makefile (713 bytes, text/plain)
2002-07-17 16:39 UTC, nkoch
no flags Details
distinfo (59 bytes, text/plain)
2002-07-17 16:39 UTC, nkoch
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description obraun 2002-07-04 23:00:06 UTC
Update databases/fastdb from 2.23 to 2.41.

Regards,
         Olli
Comment 1 Ying-Chieh Liao freebsd_committer 2002-07-05 04:08:19 UTC
State Changed
From-To: open->closed

committed, thanks
Comment 2 nkoch 2002-07-17 16:39:00 UTC
Hello.

It seems like FastDB-2.47 is working too.
I built it using the original 2.41 patch
files.
See the enclosed files for changes.
I tested FastDB under 4.6-STABLE.
Thanks for any feedback.

Best regards

Norbert Koch
demig Prozessautomatisierung GmbH
http://www.demig.de

P.S.:
  I made a simple naming change in
  FastDB2.47 locally.
  I changed:
    "typedef signed long long int8;"
  to
    "typedef signed long long int8_".

The problem is that I use FastDB
together with CommonC++ which defines
  "typedef int8_t int8;".
Both definitions are in global namespace.
So I would have two incompatible
type definitions leading to compilation errors.

If there is some interest I could
create a set of patch files.