Bug 40283 - Fix for mod_ruby installation w/ non-port apache
Fix for mod_ruby installation w/ non-port apache
Status: Closed FIXED
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s)
Any Any
: Normal Affects Only Me
Assigned To: Akinori MUSHA
Depends on:
  Show dependency treegraph
Reported: 2002-07-07 09:50 UTC by Sean Chittenden
Modified: 2002-07-12 06:00 UTC (History)
1 user (show)

See Also:

file.diff (791 bytes, patch)
2002-07-07 09:50 UTC, Sean Chittenden
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Sean Chittenden 2002-07-07 09:50:01 UTC
	As per discussion on #ruby-lang, mod_ruby (and likely many other
	mod_*) assume that everyone uses ${LOCALBASE} for installation of
	apache (esp via the ports).  Unfortunately, that's not always the
	case.  To sidestep this bullet, use of apxs is required.

Fix: Apply the attached patch to www/mod_ruby/Makefile and set APXS to whatever
is required before making/installing.  Ex:

setenv APXS /www/bin/apxs
portinstall mod_ruby
# or:
cd /usr/ports/www/mod_ruby && make APXS=/www/bin/apxs install

How-To-Repeat: 	Install a custom version of apache into a different directory
	(ex: /www) and attempt to install mod_ruby.
Comment 1 pat freebsd_committer 2002-07-12 03:24:41 UTC
Responsible Changed
From-To: freebsd-ports->knu

Over to maintainer
Comment 2 Akinori MUSHA freebsd_committer 2002-07-12 06:00:48 UTC
State Changed
From-To: open->closed

Patch applied, thanks.