Bug 41853 - patch: audio/gnump3d - fix broken build
Summary: patch: audio/gnump3d - fix broken build
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Christian Weisgerber
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2002-08-21 19:30 UTC by Adam Weinberger
Modified: 2002-08-24 21:20 UTC (History)
0 users

See Also:


Attachments
gnump3d.patch (413 bytes, patch)
2002-08-21 19:30 UTC, Adam Weinberger
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Adam Weinberger 2002-08-21 19:30:01 UTC
	on my -STABLE machine, building audio/gnump3d spits out an automake error
	right at the beginning of the build. the issue is the process used to avoid
	an automake. currently, it takes a newly generated file, and sets its time
	back perhaps a few milliseconds. this patch updates the timestamp of
	Makefile.in.

	===>  Building for gnump3d-1.0.p1
	cd . && /usr/ports/audio/gnump3d/work/gnump3d-1.0-pre1/config/missing automake-1.4 --foreign Makefile
	WARNING: `automake-1.4' is needed, and you do not seem to have it handy on your
	system.  You might have modified some files without having the
	proper tools for further handling them.  Check the `README' file,
	it often tells you about the needed prerequirements for installing
	this package.  You may also peek at any GNU archive site, in case
	some other package would contain this missing `automake-1.4' program.
	gmake: *** [Makefile.in] Error 1
	*** Error code 2

	 Stop in /usr/ports/audio/gnump3d.
Comment 1 Christian Weisgerber freebsd_committer 2002-08-22 12:29:22 UTC
Responsible Changed
From-To: freebsd-ports->naddy

I'll look into this.
Comment 2 Christian Weisgerber freebsd_committer 2002-08-23 01:42:26 UTC
State Changed
From-To: open->closed

I committed a fix. 
-CURRENT's sed preserves the original date for .bak files, 
textproc/sed_inplace does not.
Comment 3 Adam Weinberger 2002-08-23 07:19:26 UTC
this patch does not solve the problem. the error remains. automake is
only being concerned with the timestamp of Makefile.in in relation to
aclocal.m4. one way or another, Makefile.in has to end up no older than
aclocal.m4, or automake has to be hosed entirely.

-Adam
Comment 4 Adam Weinberger 2002-08-24 21:18:24 UTC
oosp - the error was indeed corrected with naddy's patch. my mistake.

-Adam