Bug 42019 - Update port: devel/distcc fix for various configure scripts
Summary: Update port: devel/distcc fix for various configure scripts
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-ports mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2002-08-26 03:30 UTC by Frerich Raabe
Modified: 2002-08-26 03:39 UTC (History)
0 users

See Also:


Attachments
file.diff (803 bytes, patch)
2002-08-26 03:30 UTC, Frerich Raabe
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Frerich Raabe 2002-08-26 03:30:01 UTC
libstdc++-v3's configure script (and others) execute commands such as
.../xgcc -B.../ conftest.C -c -S. Assuming that xgcc invokes the distcc client,
this makes the distcc client write the assembly output to conftest.o even
though it should go into conftest.s. The cause of this is that distcc currently
does not honour the fact that -S supersedes -c.
Interestingly, if you add "-o conftest.s" to the command line, it's the distcc
server that fails, claiming it couldn't find conftest.C.
The attached patch (courtesy of Alexandre Oliva <aoliva@redhat.com>
fixes this behaviour.

How-To-Repeat: Try to compile any program with both the "-c" and the "-S" parameters specified.
Comment 1 Mario Sergio Fujikawa Ferreira freebsd_committer 2002-08-26 03:39:22 UTC
State Changed
From-To: open->closed

Committed, thanks!