Bug 42390 - OpenOffice.org port fails when WRKDIRPREFIX is set
Summary: OpenOffice.org port fails when WRKDIRPREFIX is set
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-openoffice (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2002-09-03 23:10 UTC by Pat Lashley
Modified: 2002-09-11 15:29 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pat Lashley 2002-09-03 23:10:04 UTC
When attempting to build the openoffice-1.0.1 port with WRKDIRPREFIX
set, the build fails when attempting to zip up the included Mozilla
port.  The problem is that the embedded Mozilla port independantly
honors the WRKDIRPREFIX.

Fix: 

Add 'WRKDIRPREFIX=' (and explanatory comments) to mozilla/Makefile
How-To-Repeat: cd /usr/ports/editors/openoffice
WRKDIRPREFIX=/some/large/temp/area make install
Comment 1 Tetsurou Okazaki freebsd_committer 2002-09-04 10:29:45 UTC
Responsible Changed
From-To: freebsd-ports->openoffice

over to the maintainer(s)
Comment 2 Martin Blapp freebsd_committer 2002-09-11 15:29:23 UTC
State Changed
From-To: open->closed

I just committed a fix for this. Thanks !