Bug 43225 - phpPgAdmin port doesn't work with Apache2 by default
Summary: phpPgAdmin port doesn't work with Apache2 by default
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: nbm
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2002-09-22 07:10 UTC by Jason Li
Modified: 2003-02-06 09:00 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jason Li 2002-09-22 07:10:03 UTC
The phpPgAdmin port requires php4 or php3. Currently php4 supports Apache2 as well as Apache, though that's exprimental, but many people uses php4 with Apache 2.x.

I think it's important to support Apache2/php4, unfortunatelly, the port doesn't do this by default.

Fix: 

The following lines in Makefile under ports/databases/phppgadmin
.if !defined(WITH_PHP3)
RUN_DEPENDS+=   ${LOCALBASE}/libexec/apache/libphp4.so:${PORTSDIR}/www/mod_php4
.else
RUN_DEPENDS+=   ${LOCALBASE}/libexec/apache/libphp3.so:${PORTSDIR}/www/mod_php3
.endif

should consider to modify to

.if !defined(WITH_PHP3)
.if defined(WITH_APACHE2)
RUN_DEPENDS+=   ${LOCALBASE}/libexec/apache2/libphp4.so:${PORTSDIR}/www/mod_php4
.else
RUN_DEPENDS+=   ${LOCALBASE}/libexec/apache/libphp4.so:${PORTSDIR}/www/mod_php4
.endif
.else
RUN_DEPENDS+=   ${LOCALBASE}/libexec/apache/libphp3.so:${PORTSDIR}/www/mod_php3
.endif

and additional prompt may be needed.
How-To-Repeat: Make the port under a system have Apache2 and mod_php4 installed
Comment 1 Christian Weisgerber freebsd_committer 2002-10-06 02:51:40 UTC
Responsible Changed
From-To: freebsd-ports->nbm

over to maintainer
Comment 2 nbm freebsd_committer 2003-01-09 14:39:31 UTC
State Changed
From-To: open->closed

Added the option, thanks!
Comment 3 tweaky 2003-02-03 13:21:12 UTC
Content-Type: message/rfc822
From: "Georgi Hristov" <tweaky@mail.com>
Date: Mon, 3 Feb 2003 00:01:53 -0600
To: <freebsd-gnats-submit@FreeBSD.org>, <delphij@frontfree.net>
Subject: Re: ports/43225: phpPgAdmin port doesn't work with Apache2 by default
Message-Id: <000301c2cb49$c5887220$6300a8c0@pluton>


>
> I have done this ... phpPgAdmin still does not work.  I get the following
> error.
> 
> Configuration Error: You must rename/copy to config.inc.php-dist
> config.inc.php and set your appropriate settings
> 
> And I am sure that I copied the config.inc.php-dist config.inc.php  and I
> am sure I edited it correctly. I checked the permissions and they look
> allright 644 owned by www : www ...
> 
> I installed phpPg Admin with WITH_APACHE2   ....
> 
> Some information:
> FreeBSD tweaky.homeip.net 4.7-STABLE FreeBSD 4.7-STABLE #0: Mon Jan 13
> 06:40:54 CST 2003     root@tweaky.xxXXxxXX.net:/usr/obj/usr/src/sys/TWEAKY
> i386
> 
> default apache installation  --> Apache/2.0.43 Server at
> tweaky.xxXXxxXX.net Port 80
> PHP installed WITH_APACHE2
> './configure' '--with-apxs2=/usr/local/sbin/apxs' '--with-tsrm-pth'
> '--with-config-file-path=/usr/local/etc' '--enable-versioning'
> '--with-regex=system' '--without-gd' '--without-mysql'
> '--with-gd=/usr/local' '--enable-gd-native-ttf'
> '--with-freetype-dir=/usr/local' '--with-jpeg-dir=/usr/local'
> '--with-png-dir=/usr/local' '--with-zlib' '--with-bz2=/usr'
> '--with-mcrypt=/usr/local' '--with-mhash=/usr/local'
> '--with-mysql=/usr/local' '--with-pgsql=/usr/local'
> '--with-ldap=/usr/local' '--with-openssl=/usr' '--with-snmp=/usr/local'
> '--enable-ucd-snmp-hack' '--with-openssl=/usr' '--enable-ftp'
> '--with-curl=/usr/local' '--prefix=/usr/local' 'i386-portbld-freebsd4.7'
> 
> 
> I don't know what else to DO
> 
> Any recommendation would be useful.
> 
> Thanks in advance
> 

-- 
__________________________________________________________
Sign-up for your own FREE Personalized E-mail at Mail.com
http://www.mail.com/?sr=signup
Comment 4 鼛 燠 2003-02-03 13:53:41 UTC
I think the problem is, that you didn't have enabled postgresql's tcp connection. By default, the TCP connection is disabled for security reasons, only unix sockets are allowed. Therefore you might have to enable it by altering 

/usr/local/pgsql/data/postgresql.conf

hopefully this solve the problem. Actually I don't have your problem at present (the ports tree are cvsup'd today and rebuilt wholely)

Forgive me that I couldn't reply through delphij@frontfree.net because it can't be reverse-resolved.

Cheers,
Xin Li.

----- Original Message ----- 
From: "Georgi Hristov" <tweaky@mail.com>
To: <freebsd-gnats-submit@FreeBSD.org>; <delphij@frontfree.net>
Sent: Monday, February 03, 2003 2:01 PM
Subject: Re: ports/43225: phpPgAdmin port doesn't work with Apache2 by default


> I have done this ... phpPgAdmin still does not work.  I get the following
> error.
> 
> Configuration Error: You must rename/copy to config.inc.php-dist
> config.inc.php and set your appropriate settings
> 
> And I am sure that I copied the config.inc.php-dist config.inc.php  and I
> am sure I edited it correctly. I checked the permissions and they look
> allright 644 owned by www : www ...
> 
> I installed phpPg Admin with WITH_APACHE2   ....
> 
> Some information:
> FreeBSD tweaky.homeip.net 4.7-STABLE FreeBSD 4.7-STABLE #0: Mon Jan 13
> 06:40:54 CST 2003     root@tweaky.xxXXxxXX.net:/usr/obj/usr/src/sys/TWEAKY
> i386
> 
> default apache installation  --> Apache/2.0.43 Server at
> tweaky.xxXXxxXX.net Port 80
> PHP installed WITH_APACHE2
> './configure' '--with-apxs2=/usr/local/sbin/apxs' '--with-tsrm-pth'
> '--with-config-file-path=/usr/local/etc' '--enable-versioning'
> '--with-regex=system' '--without-gd' '--without-mysql'
> '--with-gd=/usr/local' '--enable-gd-native-ttf'
> '--with-freetype-dir=/usr/local' '--with-jpeg-dir=/usr/local'
> '--with-png-dir=/usr/local' '--with-zlib' '--with-bz2=/usr'
> '--with-mcrypt=/usr/local' '--with-mhash=/usr/local'
> '--with-mysql=/usr/local' '--with-pgsql=/usr/local'
> '--with-ldap=/usr/local' '--with-openssl=/usr' '--with-snmp=/usr/local'
> '--enable-ucd-snmp-hack' '--with-openssl=/usr' '--enable-ftp'
> '--with-curl=/usr/local' '--prefix=/usr/local' 'i386-portbld-freebsd4.7'
> 
> 
> I don't know what else to DO
> 
> Any recommendation would be useful.
> 
> Thanks in advance
> 
> 
Comment 5 tweaky 2003-02-03 23:20:08 UTC
I do have postmaster running with the -i option, which supposedly should allow tcpip connections.
pgsql   1634  0.0  0.7  6944 3732  p0  I     4:11PM   0:00.05 /usr/local/bin/postmaster -i (postgres)
pgsql   1636  0.0  0.7  7932 3744  p0  I     4:11PM   0:00.00 postmaster: stats buffer process    (postgres)
pgsql   1638  0.0  0.7  6988 3776  p0  I     4:11PM   0:00.01 postmaster: stats collector process    (postgres)


/usr/local/pgsql/data/postgresql.conf
-------------------------------------
 ....
tcpip_socket = true
#ssl = false
 ....

I would appreciate any other suggestions. Thanks for the timely response. 



----- Original Message -----
From: æé« Jason Li <delphij@hotmail.com>
Date: Mon, 3 Feb 2003 21:53:41 +0800
To: "Georgi Hristov" <tweaky@mail.com>, <freebsd-gnats-submit@FreeBSD.org>, <delphij@frontfree.net>
Subject: Re: ports/43225: phpPgAdmin port doesn't work with Apache2 by default

> I think the problem is, that you didn't have enabled postgresql's tcp connection. By default, the TCP connection is disabled for security reasons, only unix sockets are allowed. Therefore you might have to enable it by altering 
> 
> /usr/local/pgsql/data/postgresql.conf
> 
> hopefully this solve the problem. Actually I don't have your problem at present (the ports tree are cvsup'd today and rebuilt wholely)
> 
> Forgive me that I couldn't reply through delphij@frontfree.net because it can't be reverse-resolved.
> 
> Cheers,
> Xin Li.
> 
> ----- Original Message ----- 
> From: "Georgi Hristov" <tweaky@mail.com>
> To: <freebsd-gnats-submit@FreeBSD.org>; <delphij@frontfree.net>
> Sent: Monday, February 03, 2003 2:01 PM
> Subject: Re: ports/43225: phpPgAdmin port doesn't work with Apache2 by default
> 
> 
> > I have done this ... phpPgAdmin still does not work.  I get the following
> > error.
> > 
> > Configuration Error: You must rename/copy to config.inc.php-dist
> > config.inc.php and set your appropriate settings
> > 
> > And I am sure that I copied the config.inc.php-dist config.inc.php  and I
> > am sure I edited it correctly. I checked the permissions and they look
> > allright 644 owned by www : www ...
> > 
> > I installed phpPg Admin with WITH_APACHE2   ....
> > 
> > Some information:
> > FreeBSD tweaky.homeip.net 4.7-STABLE FreeBSD 4.7-STABLE #0: Mon Jan 13
> > 06:40:54 CST 2003     root@tweaky.xxXXxxXX.net:/usr/obj/usr/src/sys/TWEAKY
> > i386
> > 
> > default apache installation  --> Apache/2.0.43 Server at
> > tweaky.xxXXxxXX.net Port 80
> > PHP installed WITH_APACHE2
> > './configure' '--with-apxs2=/usr/local/sbin/apxs' '--with-tsrm-pth'
> > '--with-config-file-path=/usr/local/etc' '--enable-versioning'
> > '--with-regex=system' '--without-gd' '--without-mysql'
> > '--with-gd=/usr/local' '--enable-gd-native-ttf'
> > '--with-freetype-dir=/usr/local' '--with-jpeg-dir=/usr/local'
> > '--with-png-dir=/usr/local' '--with-zlib' '--with-bz2=/usr'
> > '--with-mcrypt=/usr/local' '--with-mhash=/usr/local'
> > '--with-mysql=/usr/local' '--with-pgsql=/usr/local'
> > '--with-ldap=/usr/local' '--with-openssl=/usr' '--with-snmp=/usr/local'
> > '--enable-ucd-snmp-hack' '--with-openssl=/usr' '--enable-ftp'
> > '--with-curl=/usr/local' '--prefix=/usr/local' 'i386-portbld-freebsd4.7'
> > 
> > 
> > I don't know what else to DO
> > 
> > Any recommendation would be useful.
> > 
> > Thanks in advance
> > 
> 
-- 
__________________________________________________________
Sign-up for your own FREE Personalized E-mail at Mail.com
http://www.mail.com/?sr=signup
Comment 6 鼛 燠 2003-02-05 21:44:17 UTC
V2VsbC4uLiBJIHRoaW5rIHRoZXJlIHNob3VsZCBiZSBzb21ldGhpbicgd3JvbmcgZHVyaW5nIGlu
c3RhbGxhdGlvbi4gV291bGQgeW91IHBsZWFzZSBzZW5kIGEgbmV3IFBSIHdpdGggYSBtb3JlIGRl
dGFpbGVkIGVudmlyb25tZW50IGRlc2NyaXB0aW9uLCBpLmUuIHRoZSB1bmFtZSAtYSBvdXRwdXQs
IHBhY2thZ2UgeW91IGhhdmUgaW5zdGFsbGVkLCB0aGUgY29uZmlndXJhdGlvbiBzY3JpcHQgb2Yg
cGhwUGdBZG1pbiwgYXMgd2VsbCBhcyBwb3N0Z3Jlc3FsIGNvbmZpZ3VyYXRpb24/IFBsZWFzZSBr
ZWVwIHNlbnNpdGl2ZSBpbmZvcm1hdGlvbiBsaWtlIHBhc3N3b3JkcyBhcyAiKioqIiwgdGhpcyB3
b3VsZCBiZSBoZWxwZnVsIGZvciBtZSB0byBzZXQgdXAgYSBuZXcgZW52aXJvbm1lbnQgYW5kIHJl
Y3VyIHlvdXIgc2l0dWF0aW9uLg0KDQpCZWNhdXNlIGN1cnJlbnRseSBJIGFtIGluIHZhY2F0aW9u
LCB0aGUgcmVwbHkgbWlnaHQgbm90IGJlIGJldGltZXMsIHBsZWFzZSBwYXJkb24gdGhpcy4NCg0K
VGhhbmtzLg0KDQpYaW4gTGksDQpGcm9udGZyZWUgVGVjaG5vbG9neSBOZXR3b3JrDQoNCi0tLS0t
IE9yaWdpbmFsIE1lc3NhZ2UgLS0tLS0gDQpGcm9tOiAiR2VvcmdpIEhyaXN0b3YiIDx0d2Vha3lA
bWFpbC5jb20+DQpUbzogPGRlbHBoaWpAaG90bWFpbC5jb20+OyA8ZnJlZWJzZC1nbmF0cy1zdWJt
aXRARnJlZUJTRC5vcmc+OyA8ZGVscGhpakBmcm9udGZyZWUubmV0Pg0KU2VudDogVHVlc2RheSwg
RmVicnVhcnkgMDQsIDIwMDMgNzoyMCBBTQ0KU3ViamVjdDogUmU6IHBvcnRzLzQzMjI1OiBwaHBQ
Z0FkbWluIHBvcnQgZG9lc24ndCB3b3JrIHdpdGggQXBhY2hlMiBieSBkZWZhdWx0DQoNCg0KPiAN
Cj4gSSBkbyBoYXZlIHBvc3RtYXN0ZXIgcnVubmluZyB3aXRoIHRoZSAtaSBvcHRpb24sIHdoaWNo
IHN1cHBvc2VkbHkgc2hvdWxkIGFsbG93IHRjcGlwIGNvbm5lY3Rpb25zLg0KPiBwZ3NxbCAgIDE2
MzQgIDAuMCAgMC43ICA2OTQ0IDM3MzIgIHAwICBJICAgICA0OjExUE0gICAwOjAwLjA1IC91c3Iv
bG9jYWwvYmluL3Bvc3RtYXN0ZXIgLWkgKHBvc3RncmVzKQ0KPiBwZ3NxbCAgIDE2MzYgIDAuMCAg
MC43ICA3OTMyIDM3NDQgIHAwICBJICAgICA0OjExUE0gICAwOjAwLjAwIHBvc3RtYXN0ZXI6IHN0
YXRzIGJ1ZmZlciBwcm9jZXNzICAgIChwb3N0Z3JlcykNCj4gcGdzcWwgICAxNjM4ICAwLjAgIDAu
NyAgNjk4OCAzNzc2ICBwMCAgSSAgICAgNDoxMVBNICAgMDowMC4wMSBwb3N0bWFzdGVyOiBzdGF0
cyBjb2xsZWN0b3IgcHJvY2VzcyAgICAocG9zdGdyZXMpDQo+IA0KPiANCj4gL3Vzci9sb2NhbC9w
Z3NxbC9kYXRhL3Bvc3RncmVzcWwuY29uZg0KPiAtLS0tLS0tLS0tLS0tLS0tLS0tLS0tLS0tLS0t
LS0tLS0tLS0tDQo+ICAuLi4uDQo+IHRjcGlwX3NvY2tldCA9IHRydWUNCj4gI3NzbCA9IGZhbHNl
DQo+ICAuLi4u