Bug 45256 - games/conquest does not install
Summary: games/conquest does not install
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: markp
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2002-11-13 03:00 UTC by Mark Linimon
Modified: 2002-11-19 11:57 UTC (History)
0 users

See Also:


Attachments
file.diff (484 bytes, patch)
2002-11-13 03:00 UTC, Mark Linimon
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Linimon 2002-11-13 03:00:05 UTC
	The port refuses to install citing 'illegal group'.  It looks
	as though there is code in the Makefile to remove the chgrp
	command that fails -- but that code appears to be Perl-specific.
	I tried to make the code sed-ful but failed.

	I also tried both the port version in the Makefile, and the latest
	one.  No difference.  FWIW, the patch below at least reflects the
	latest port version.

Fix: (for version update only:)
How-To-Repeat: 	make install
Comment 1 Edwin Groothuis freebsd_committer 2002-11-14 08:47:59 UTC
Responsible Changed
From-To: freebsd-ports->edwin

I've caused the problem, I'll take care of it.
Comment 2 edwin 2002-11-14 08:48:53 UTC
I've just commited a patch so that it installs again (at least on
my computer). Please see if it fixes that. Regarding the patch for
the new version, I'll assign this PR to the maintainer the moment
you confirm it is installing again.

Edwin

-- 
Edwin Groothuis      |            Personal website: http://www.MavEtJu.org
edwin@mavetju.org    |    Weblog: http://www.mavetju.org/weblog/weblog.php 
bash$ :(){ :|:&};:   | Interested in MUDs? http://www.FatalDimensions.org/
Comment 3 Edwin Groothuis freebsd_committer 2002-11-15 00:02:58 UTC
Responsible Changed
From-To: edwin->markp

Got confirmation of submitter that the installing part works, over 
to maintainer for the upgrade to 7.1.2,
Comment 4 mark 2002-11-18 13:01:44 UTC
I've just taken a quick look at the update. The upgrade to 7.1.2
requires the regexs to be reworked and the plist to be updated so the
port functions properly.

I'll take a look on the weekend, unless someone beats me to it ;).

-- 
Mark Pulford <mark@kyne.com.au>    10.0 times 0.1 is hardly ever 1.0
Comment 5 markp freebsd_committer 2002-11-19 11:56:23 UTC
State Changed
From-To: open->closed

Committed, thanks. I've updated the build scripts to work with the new 
version. State data has been moved to /var/games/conquest from etc/conquest.