Bug 46062 - Remove skel from BSD.root.dist.
Summary: Remove skel from BSD.root.dist.
Status: Closed FIXED
Alias: None
Product: Base System
Classification: Unclassified
Component: conf (show other bugs)
Version: 5.0-CURRENT
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-bugs (Nobody)
URL:
Keywords:
: 218897 (view as bug list)
Depends on:
Blocks:
 
Reported: 2002-12-07 14:30 UTC by Carl Schmidt
Modified: 2019-02-22 17:14 UTC (History)
5 users (show)

See Also:


Attachments
BSD.root.dist.diff (229 bytes, patch)
2002-12-07 14:30 UTC, Carl Schmidt
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Carl Schmidt 2002-12-07 14:30:07 UTC
Remove /etc/skel from BSD.root.dist.  It seems to be there for possibly
historical reasons (or not).  It does not seem to serve an actual purpose.

How-To-Repeat: Not applicable.
Comment 1 Kris Kennaway freebsd_committer 2003-07-13 00:46:44 UTC
Responsible Changed
From-To: freebsd-bugs->kris

I am currently checking for any remaining references in the 
source code.
Comment 2 Alex Kozlov 2007-02-21 19:26:57 UTC
Hi

Are You have finished your checking?


--
Adios
Comment 3 Kris Kennaway freebsd_committer 2007-02-21 19:34:55 UTC
Responsible Changed
From-To: kris->freebsd-bugs

I guess someone else might have more interest in this (probably simple) PR.
Comment 4 Remko Lodder freebsd_committer 2007-02-21 20:16:53 UTC
Responsible Changed
From-To: freebsd-bugs->remko

I'll take it.
Comment 5 Alex Kozlov 2007-02-21 20:39:18 UTC
Hi

cd /usr/src; grep -w skel -r * do not show any references to /etc/skel.
Still, it may be a good idea to replace /etc/skel with a symlink
to /usr/share/skel


--
Adios
Comment 6 Remko Lodder freebsd_committer 2012-09-27 08:38:32 UTC
Responsible Changed
From-To: remko->freebsd-bugs

reassign to the pool
Comment 7 Enji Cooper freebsd_committer 2015-11-10 10:23:14 UTC
/etc/skel is used on Linux, NetBSD, OpenBSD, and Solaris for skeleton files. FreeBSD never implemented them this way.

Taking -- awaiting feedback on -arch@.
Comment 8 Miroslav Lachman 2015-11-10 13:22:29 UTC
I am suggesting change in opposite direction. Make /etc/skel as real directory and make symlink from /usr/share/skel pointing to /etc/skel.
Because in current state existing files in /usr/share/skel "should not" be modified. /usr/share/skel is not handled by mergemaster (nor freebsd-update) so it is rewritten on each update with distribution default files without notice.
If /etc/skel will be used, it will easily be handled by mergemaster and FreeBSD will use the same directory as other widely used operating systems.
Comment 9 Enji Cooper freebsd_committer 2017-11-05 20:42:12 UTC
Untaking due to bikeshed-prone nature of bug.
Comment 10 Eitan Adler freebsd_committer freebsd_triage 2017-12-31 07:19:31 UTC
*** Bug 218897 has been marked as a duplicate of this bug. ***
Comment 11 commit-hook freebsd_committer 2017-12-31 07:26:14 UTC
A commit references this bug:

Author: eadler
Date: Sun Dec 31 07:25:56 UTC 2017
New revision: 327421
URL: https://svnweb.freebsd.org/changeset/base/327421

Log:
  mtree: remove /etc/skel

  We use /usr/share/skel instead of /etc/skel. The existence of /etc/skel
  has confused people.

  PR:		46062 (submitted 2002-12-07)
  PR:		218897
  Submitted by:	carl@slackerbsd.org
  Submitted by:	asv@inhio.net

Changes:
  head/ObsoleteFiles.inc
  head/etc/mtree/BSD.root.dist
Comment 12 Eitan Adler freebsd_committer freebsd_triage 2017-12-31 07:27:50 UTC
This will be fixed in FreeBSD 12.0. I do not plan on MFCing this change unless people ask for it.