Bug 46723 - Update www/p5-CGI-SpeedyCGI to 2.21
Summary: Update www/p5-CGI-SpeedyCGI to 2.21
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-ports-bugs (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-01-03 14:10 UTC by Lars Thegler
Modified: 2003-03-01 01:33 UTC (History)
1 user (show)

See Also:


Attachments
file.diff (733 bytes, patch)
2003-01-03 14:10 UTC, Lars Thegler
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Lars Thegler 2003-01-03 14:10:01 UTC
Update port www/p5-CGI-SpeedyCGI to version 2.21.

Fix: Apply this diff:

--cut--
Comment 1 Pete Fritchman freebsd_committer 2003-01-06 01:54:05 UTC
===>  Configuring for p5-CGI-SpeedyCGI-2.21

Optional mod_speedycgi support.

Mod_speedycgi increases performance under Apache by avoiding the fork/exec
overhead associated with each request under normal SpeedyCGI.  However, it
requires a working copy of "apxs" in your path, Apache with mod_so
support, and additional Apache configuration.

Compile mod_speedycgi (default no)? 
%%

You either need to mark the port interactive, or (what I would
recommend) patching Makefile.PL to the desired answer.  I answered no
and it still tried to install mod_speedycgi on the make install stage.

--pete
Comment 2 Lars Thegler 2003-01-06 16:09:39 UTC
You've got a very valid point there. Sorry I missed this. It seems there is
an error in the distribution - it will attempt to install mod_speedycgi,
irrepective of the answer given in the configuration dialogue. I've reported
this to the author.

I've disabled the mod_speedycgi stuff in the Makefile.PL - this should be a
separate port anyway (e.g. "www/mod_speedycgi"), so the following patch file
should be added to the port:

-- files/patch-Makefile.PL begin --
--- Makefile.PL.orig    Wed Sep 18 08:21:06 2002
+++ Makefile.PL Mon Jan  6 15:51:55 2003
@@ -6,26 +6,26 @@
     import SpeedyMake qw(%write_makefile_common);
 }

-print <<END;
-
-Optional mod_speedycgi support.
-
-Mod_speedycgi increases performance under Apache by avoiding the fork/exec
-overhead associated with each request under normal SpeedyCGI.  However, it
-requires a working copy of "apxs" in your path, Apache with mod_so
-support, and additional Apache configuration.
-
-END
-print "Compile mod_speedycgi (default no)? ";
+#print <<END;
+#
+#Optional mod_speedycgi support.
+#
+#Mod_speedycgi increases performance under Apache by avoiding the fork/exec
+#overhead associated with each request under normal SpeedyCGI.  However, it
+#requires a working copy of "apxs" in your path, Apache with mod_so
+#support, and additional Apache configuration.
+#
+#END
+#print "Compile mod_speedycgi (default no)? ";

 my @dirs = qw(src speedy_backend speedy);
 my $macro = $write_makefile_common{macro};
-if (<STDIN> =~ /y/i) {
-    die "ERROR: Could not find a working copy of 'apxs' in your path.\n"
-       unless $macro->{APACHE_APXS_WORKS};
-    print "Compiling for Apache version $macro->{APACHE_VERSION}\n";
-    push(@dirs, $macro->{MOD_SPEEDYCGI_DIR});
-}
+#if (<STDIN> =~ /y/i) {
+#    die "ERROR: Could not find a working copy of 'apxs' in your path.\n"
+#      unless $macro->{APACHE_APXS_WORKS};
+#    print "Compiling for Apache version $macro->{APACHE_VERSION}\n";
+#    push(@dirs, $macro->{MOD_SPEEDYCGI_DIR});
+#}

 WriteMakefile(
     NAME               => 'CGI::SpeedyCGI',
@@ -47,12 +47,12 @@
 sub postamble {
     my $extra = SpeedyMake->optdefs_cmds('src');
     my $test_install_extra;
-    if (my $mod_dir = $macro->{MOD_SPEEDYCGI_DIR}) {
-       $extra .=
-           "\ninstall ::\n\tcd $mod_dir && \$(MAKE) install\n";
-       $test_install_extra =
-           "\t\@cd $mod_dir && \$(MAKE) test_install \$(PASTHRU)\n";
-    }
+#    if (my $mod_dir = $macro->{MOD_SPEEDYCGI_DIR}) {
+#      $extra .=
+#          "\ninstall ::\n\tcd $mod_dir && \$(MAKE) install\n";
+#      $test_install_extra =
+#          "\t\@cd $mod_dir && \$(MAKE) test_install \$(PASTHRU)\n";
+#    }

 '
 test_install:
-- files/patch-Makefile.PL end --
Comment 3 Pete Fritchman freebsd_committer 2003-01-09 05:25:01 UTC
Ok, things are looking better except "make test" is failing:

http://absolutbsd.org/petef/maketest.out

Details on my system:

pluto(~) [6] > uname -a
FreeBSD pluto.databits.net 5.0-RC FreeBSD 5.0-RC #1: Tue Jan  7 20:22:07
EST 2003     root@pluto.databits.net:/usr/obj/usr/src/sys/PLUTO  i386
pluto(~) [7] > perl -v

This is perl, v5.6.1 built for i386-freebsd

Copyright 1987-2001, Larry Wall

Perl may be copied only under the terms of either the Artistic License
or the
GNU General Public License, which may be found in the Perl 5 source kit.

Complete documentation for Perl, including FAQ lists, should be found on
this system using `man perl' or `perldoc perl'.  If you have access to
the
Internet, point your browser at http://www.perl.com/, the Perl Home
Page.

pluto(~) [8] > 

--pete
Comment 4 Anton Berezin freebsd_committer 2003-01-31 18:12:34 UTC
Pete Fritchman <petef@FreeBSD.org> wrote:

> Ok, things are looking better except "make test" is failing:
 
>  http://absolutbsd.org/petef/maketest.out

Pete, I was not able to reproduce failing tests (tested with several
different perls on a pristine jail with no packages), and the URL above
is no longer valid.  I am inclined to commit the latest update from
Lars.  Care to comment?

Cheers,
^Anton.
-- 
| Anton Berezin                |      FreeBSD: The power to serve |
| catpipe Systems ApS   _ _ |_ |           http://www.FreeBSD.org |
| tobez@catpipe.net    (_(_||  |                tobez@FreeBSD.org | 
| +45 7021 0050                |         Private: tobez@tobez.org |
Comment 5 bra 2003-02-10 10:29:51 UTC
Hello,

I've tried the patch, the port seems to build and install correctly.

Anton, could you please commit it?

$ uname -a
FreeBSD cimtar.bmf.hu 5.0-RELEASE FreeBSD 5.0-RELEASE #2: Wed Jan 22
10:45:31 CET 2003     root@ns.bmf.hu:/usr/obj/usr/src/sys/OBERON  i386
$ perl -v

This is perl, v5.8.0 built for i386-freebsd

Copyright 1987-2002, Larry Wall

Perl may be copied only under the terms of either the Artistic License or
the
GNU General Public License, which may be found in the Perl 5 source kit.

Complete documentation for Perl, including FAQ lists, should be found on
this system using `man perl' or `perldoc perl'.  If you have access to the
Internet, point your browser at http://www.perl.com/, the Perl Home Page.

Thanks,
----------[ Free Software ISOs - http://www.fsn.hu/?f=download ]----------
Attila Nagy					e-mail: Attila.Nagy@fsn.hu
Free Software Network (FSN.HU)		  phone @work: +361 210 1415 (194)
						cell.: +3630 306 6758
Comment 6 Yen-Ming Lee freebsd_committer 2003-03-01 01:33:04 UTC
State Changed
From-To: open->closed

Committed, thanks.