Bug 47109 - science/babel and biology/babel binary names conflict
Summary: science/babel and biology/babel binary names conflict
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-ports-bugs (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-01-15 17:10 UTC by gjohnson
Modified: 2003-04-05 09:10 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description gjohnson 2003-01-15 17:10:01 UTC
        The binary name that the science/openbabel port installs is
        called babel.  This is the same as the binary installed by the
        biology/babel port.  These two ports have the same purpose and
        openbabel is meant to be a replacement for babel, which is no
        longer in development.  However, the openbabel project does
        not have all of the features of the original babel nor does it
        support all of the file formats of the original.  Therefore, the
        older version of babel, installed by the biology/babel port, is
        still very viable.

        As such, I think the binary installed by openbabel should be
        changed to something else. The name, "openbabel", seems like a
        good choice.  Perhaps some others feel that the older babel port
        should change its name though.  Either way, one of them must be
        changed to avoid the conflict.

Fix: 

Change the name of the installed binary from babel to
        something else for either the science/openbabel port or the
        biology/babel port.  No patch provided because a decision needs
        to be made about which one changes.  I vote for having the
        science/openbabel port install its binary name as "openbabel".
How-To-Repeat: 
        <code/input/activities to reproduce the problem (multiple
        lines)>
Comment 1 Edwin Groothuis freebsd_committer 2003-04-05 09:10:50 UTC
State Changed
From-To: open->closed

Commited, thanks!