Bug 47363 - databases/gdbm won't install compatibility files
Summary: databases/gdbm won't install compatibility files
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Yar Tikhiy
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-01-22 14:30 UTC by Yar Tikhiy
Modified: 2003-01-22 17:06 UTC (History)
1 user (show)

See Also:


Attachments
file.diff (1.52 KB, patch)
2003-01-22 14:30 UTC, Yar Tikhiy
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Yar Tikhiy freebsd_committer 2003-01-22 14:30:01 UTC
	At some point of gdbm development, Unix dbm/ndbm compatibility
	functions were moved from the main library to libgdbm_compat,
	and an additional make(1) target, install-compat, was introduced
	to install the compatibility files.

	The FreeBSD databases/gdbm port can't install those files, though.

Fix: The below patch adds a make(1) variable, WITH_COMPAT,
which allows one to control whether the compatibility
files will be installed.

If the port's maintainer has no objections, I can commit
this patch.
How-To-Repeat: 	Install databases/gdbm.
Comment 1 Cyrille Lefevre 2003-01-22 15:14:47 UTC
On Wed, Jan 22, 2003 at 05:22:12PM +0300, Yar Tikhiy wrote:
> 
> If the port's maintainer has no objections, I can commit
> this patch.

no, I have no objection. thanks :)

Cyrille.
-- 
Cyrille Lefevre                 mailto:cyrille.lefevre@laposte.net
Comment 2 Yar Tikhiy freebsd_committer 2003-01-22 17:02:13 UTC
State Changed
From-To: open->closed

Patch committed. 
Thank you Cyrille for reviewing it. 


Comment 3 Yar Tikhiy freebsd_committer 2003-01-22 17:02:13 UTC
Responsible Changed
From-To: freebsd-ports-bugs->yar

I'm the person to blame for this change.