Bug 48555 - www/frontpage* - File permissions changed after install
Summary: www/frontpage* - File permissions changed after install
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-ports-bugs (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-02-22 04:50 UTC by Scot W. Hetzel
Modified: 2003-02-24 16:24 UTC (History)
1 user (show)

See Also:


Attachments
file.diff (1.58 KB, patch)
2003-02-22 04:50 UTC, Scot W. Hetzel
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Scot W. Hetzel 2003-02-22 04:50:11 UTC
	The language frontpage ports are changing the ownership and permissions
	of files already installed by the main frontpage ports.

Fix: The problem is that the frontpage-* language ports run the fp_set_perm.sh
	script after the extentions have been installed into the PREFIX/frontpage
	directory.  The www/frontpage port relied on the fp_install.sh script to
	set these permissions.  I fixed this problem by running the fp_set_perm.sh
	script after the www/frontpage has finished installing.

	The patch also removes the extra file created by the REINPLACE_CMD in both
	www/frontpage and www/frontpage-ar.
How-To-Repeat: 	Install www/frontpage, then install any of the frontpage-* language ports.
Comment 1 Yen-Ming Lee freebsd_committer 2003-02-24 16:24:04 UTC
State Changed
From-To: open->closed

Committed, thanks.