Bug 50089 - GnuCash-1.8.1_3 fails at startup: scm date util inexact->exact
GnuCash-1.8.1_3 fails at startup: scm date util inexact->exact
Status: Closed FIXED
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s)
Latest
Any Any
: Normal Affects Only Me
Assigned To: gnome
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-03-18 03:30 UTC by chris
Modified: 2003-04-03 04:05 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description chris 2003-03-18 03:30:01 UTC
Built gnucash from ports.  Did a portupgrade -R gnucash-1'*' to make
sure.  Had to comment out /usr/include/math.h:40 which defines
INFINITY clashing with guppi's use of it (see PR ports/48839).

chris@Pectopah<102>  pkg_info -c gnucash'*'
Information for gnucash-1.8.1_3:

Fix: 

I have no idea what the above LISP mutation is telling me, sorry :-(
How-To-Repeat: 
Start it up on command line with "gnucash".  Splash screen comes up
then it dies with the following trace:

chris@Pectopah<101> gnucash
;;; The module name (ice-9 and-let*) is deprecated.
;;; Use (ice-9 and-let-star) instead.

Backtrace:
12  (or (try-module-linked name) (try-module-autoload name) ...)
13* [try-module-autoload (gnucash report taxtxf)]
14  (let* (# # # #) (resolve-module dir-hint-module-name #f) (and # #))
    ...
15  (let ((didit #f)) (dynamic-wind (lambda () #) (lambda () #) ...) ...)
16* [dynamic-wind #<procedure ()> #<procedure ()> #<procedure ()>]
17* [#<procedure ()>]
18* (let ((full #)) (if full (begin # #)))
19  (if full (begin (save-module-excursion (lambda () #)) (set! didit #t)))
20  (begin (save-module-excursion (lambda () #)) (set! didit #t))
21* [save-module-excursion #<procedure ()>]
22  (let (# #) (dynamic-wind # thunk #))
23  [dynamic-wind #<procedure ()> #<procedure ()> #<procedure ()>]
24* [#<procedure ()>]
25* [primitive-load "/usr/X11R6/share/gnome/gnucash/guile-modules/gnucash/repo$
26* (define bdtm (let ((result #)) (set-tm:mday result 16) ...))
27* (let ((result (gnc:timepair->date today))) (set-tm:mday result 16) ...)
28* [gnc:timepair->date (1047920400 . 0)]
29  [localtime ...
30* [gnc:timepair->secs (1047920400 . 0)]
31  [inexact->exact 1047920400.0]

/usr/X11R6/share/gnome/gnucash/scm/date-utilities.scm:25:3: In procedure inexact->exact in expression (inexact->exact (+ # #)):
/usr/X11R6/share/gnome/gnucash/scm/date-utilities.scm:25:3: Numerical overflow
Comment 1 nork freebsd_committer 2003-03-19 16:19:24 UTC
Responsible Changed
From-To: freebsd-ports-bugs->gnome

Anyone, please check this PR.
Comment 2 Joe Marcus Clarke freebsd_committer 2003-03-19 16:21:27 UTC
State Changed
From-To: open->feedback

I am unable to reproduce this problem, and I know other users that 
also have no problems with GnuCash 1.8.1.  Make sure your ports are all 
up-to-date (especially guile), then you might try updating to GnuCash 1.8.2 
after applying the patch from http://www.marcuscom.com/downloads/freeze/. 
Let me know if that fixes it.
Comment 3 Joe Marcus Clarke freebsd_committer 2003-04-03 04:04:52 UTC
State Changed
From-To: feedback->closed

This should now be fixed in GnuCash 1.8.2.