Bug 50135 - conflicting types for mkdir() and rename() in elm 2.5.6
Summary: conflicting types for mkdir() and rename() in elm 2.5.6
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-ports-bugs (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-03-19 19:50 UTC by Christopher Nehren
Modified: 2003-09-09 17:32 UTC (History)
0 users

See Also:


Attachments
patch-aa (1.62 KB, text/plain)
2003-09-03 18:37 UTC, Jonathan Lennox
no flags Details
file.dat (43 bytes, text/plain; charset=us-ascii)
2003-09-03 18:37 UTC, Jonathan Lennox
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Christopher Nehren 2003-03-19 19:50:13 UTC
While building elm 2.5.6, the build fails with errors regarding conflicting types for mkdir() and rename().

Fix: 

Define MKDIR and RENAME in a scope visible to work/elm-2.5.6/hdrs/elm_lib.h . Defining them right before the #ifndef lines in elm_lib.h does solve the problem, if in a kludgish way.
How-To-Repeat: 
cd $PREFIX/ports/mail/elm && make install
Comment 1 Jonathan Lennox 2003-09-03 18:37:32 UTC
I've figured out this problem.

The problem is that elm's Configure script uses 'nm' to extract
symbols from libc, to determine what functions are available on the
system.

However, the script isn't expecting symbols of type 'W' (weak) to show
up. In FreeBSD 5.x, a number of functions in libc are weak symbols.

The solution is to patch elm's Configure script as indicated by the
attached patch.  (I've attached the new patch-aa file; this
incorporates the existing patch-aa as well as the new patch I've
introduced.)  The fix changes '[ATDS]', in the sed expression run over
the output of 'nm', to '[ATDSW]'.
Comment 2 Greg Lewis freebsd_committer 2003-09-09 17:31:30 UTC
State Changed
From-To: open->closed

Committed the same patch from earlier PR 47379.