Bug 50338 - Patch: update devel/rpc2 to version 1.15
Summary: Patch: update devel/rpc2 to version 1.15
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-ports-bugs (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-03-27 10:20 UTC by Tim J. Robbins
Modified: 2003-03-28 05:12 UTC (History)
0 users

See Also:


Attachments
file.diff (811 bytes, patch)
2003-03-27 10:20 UTC, Tim J. Robbins
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Tim J. Robbins 2003-03-27 10:20:19 UTC
This patch updates devel/rpc2 to version 1.15, and is part of a series of
patches to update the Coda-related libraries to their latest versions.
Important changes, from the NEWS file:
* Fixed memory corruption when packing an RPC2_String with the MultiRPC
  packing routines.
* Solved slow writes and disconnections caused by excessive packet drops when
  a masquerading client is sending SFTP packets on a fast network to a
  (slower) server.

How-To-Repeat: N/A
Comment 1 Kevin Lo freebsd_committer 2003-03-28 05:11:24 UTC
State Changed
From-To: open->closed

Committed, thanks.