Bug 50595 - editors/openoffice (1.0.2) compilation hangs
Summary: editors/openoffice (1.0.2) compilation hangs
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-openoffice (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-04-04 09:50 UTC by David Holm
Modified: 2003-04-29 14:05 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David Holm 2003-04-04 09:50:13 UTC
I'm trying to upgrade my openoffice 1.0.2-2 to a newer 1.0.2-2 (or rather portupgrade wants to do it).
Some time through the compilation it just hangs and top tells me that saxparser is using 97.5% CPU. Yesterday I realized it had been running for 45h so I killed the compilation and restarted it, but this morning the same thing had happened.
The last lines to show up during compilation are:
caledata_is_IS.obj
echo dummy remove 
dummy remove
rm -f ../../unxfbsd.pro/misc/localedata_it_CH.cxx
../../unxfbsd.pro/bin/saxparser it_CH it_CH.xml ../../unxfbsd.pro/misc/localedata_it_CH.cxx ../../unxfbsd.pro/bin/applicat.rdb

and if I abort it with ctrl+c it says:
---* TG_SLO.MK *---

ERROR: Error 65280 occurred while making /usr/ports/editors/openoffice/work/oo_1.0.2_src/i18npool/source/localedata_ascii


---* TG_SLO.MK *---

I'm compiling it with gcc32-20030326 (from ports) and with the following flags set in make.conf:

CPUFLAGS?=i686
CFLAGS= -O3 -pipe
CXXFLAGS= ${CFLAGS} -fmemoize-lookups -fsave-memoized

WITHOUT_KDE=true
WITH_HOTSPOT=true
WITH_NATIVE_THREADS=true
WANT_THREADS_SUPPORT=true
WITH_THREADS=true
WITH_TTF_BYTECODE_ENABLED=true

How-To-Repeat: I'm not sure how to repeat this as I have installed an older version of 1.0.2 from ports successfully.
Comment 1 Tilman Keskinoz freebsd_committer 2003-04-05 19:39:20 UTC
Responsible Changed
From-To: freebsd-ports-bugs->openoffice

Over to Maintainers
Comment 2 Martin Blapp freebsd_committer 2003-04-05 19:47:18 UTC
State Changed
From-To: open->analyzed

Unfortunatly this can still happen. I experience it 
with 1 of 100 builds. The problem is buggy locking 
in rtld, which needs to be cleaned up. 

In the meantime just restart the compile and it will 
not hang anymore.
Comment 3 Martin Blapp freebsd_committer 2003-04-29 14:04:35 UTC
State Changed
From-To: analyzed->closed

rtld bug. May hopefully change when we use kernel threads. 
Until then we have to live with it.