Bug 50900 - py-gnome2 hates installed older versions [patch]
Summary: py-gnome2 hates installed older versions [patch]
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-ports-bugs mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-04-13 15:20 UTC by Jan Hornyak
Modified: 2003-04-14 00:32 UTC (History)
0 users

See Also:


Attachments
file.diff (259 bytes, patch)
2003-04-13 15:20 UTC, Jan Hornyak
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Hornyak 2003-04-13 15:20:07 UTC
x11-toolkits/py-gnome2 have pkg-install script called in pre-build target,
checking for existency of py-gnome installation on the system. This script
prevent upgrading of py-gnome2 using portupgrade, in fact, it prevents
building py-gnome2 if any version of py-gnome or py-gnome2 is installed
on the system.

Also the script itself is technically incorrect, because it detects
any version of py-gnome as py-gnome1 because py-gnome2 installs
as py-gnome-1.99.16

Fix: Move script execution to pre-install stage.
How-To-Repeat: 
===>  Building for py-gnome-1.99.16_1
py-gnome-1.99.15_1  A set of Python bindings for GNOME 2
py-gnome for GTK+ 1.x was detected.
This packages cannot coexist with py-gnome.
*** Error code 1

Stop in /usr/ports/x11-toolkits/py-gnome2.
Comment 1 Joe Marcus Clarke freebsd_committer 2003-04-14 00:32:06 UTC
State Changed
From-To: open->closed

I fixed the pkg-instal script.  Thanks for reporting.