Bug 51579 - XFree86 - memory leak in XvQueryAdaptors()
Summary: XFree86 - memory leak in XvQueryAdaptors()
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Eric Anholt
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-04-29 12:50 UTC by Alexey Dokuchaev
Modified: 2003-04-30 01:16 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexey Dokuchaev 2003-04-29 12:50:10 UTC
There is a small leak in XvQueryAdaptors() function of XFree86 
(xc/lib/Xv/Xv.c), reported by Jim Radford.  The problem is
fixed in their CVS as of version 1.17, 2003/04/28 16:56:27.

Fix: 

See their CVS:

http://cvsweb.xfree86.org/cvsweb/xc/lib/Xv/Xv.c.diff?r1=1.16&r2=1.17&f=h
How-To-Repeat: N/A
Comment 1 Tilman Keskinoz freebsd_committer 2003-04-29 22:40:56 UTC
Responsible Changed
From-To: freebsd-ports-bugs->anholt

Over to Maintainer
Comment 2 Eric Anholt freebsd_committer 2003-04-30 01:16:42 UTC
State Changed
From-To: open->closed

Committed, thanks!