Bug 52154 - chinese/xemacs21 configure error
chinese/xemacs21 configure error
Status: Closed FIXED
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s)
Any Any
: Normal Affects Only Me
Assigned To: keith
Depends on:
  Show dependency treegraph
Reported: 2003-05-13 09:40 UTC by freebsd
Modified: 2003-07-02 12:30 UTC (History)
1 user (show)

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description freebsd 2003-05-13 09:40:09 UTC
	chinese/xemacs21 fails with the following error

===>  Configuring for zh-xemacs-mule-21.4.12
./configure: Usage error:
  Unrecognized argument: xlib
  Use `./configure --help' to show usage.
===>  Script "configure" failed unexpectedly.
      Please report the problem to kiri@FreeBSD.org [maintainer] and attach
      including the output of the failure of your make command. Also, it might
      be a good idea to provide an overview of all packages installed on your
      system (e.g. an `ls /var/db/pkg`).
*** Error code 1

Stop in /usr/ports/chinese/xemacs21.

	Note: config.log was empty


Change the line in Makefile

		WITH_XIM=       xlib

		WITH_XIM=       --with-xim=xlib

	It will then compile and install
	cd /usr/ports/chinese/xemacs21
Comment 1 Tilman Keskinoz freebsd_committer 2003-05-13 15:07:35 UTC
Responsible Changed
From-To: freebsd-ports-bugs->keith

over to maintainer
Comment 2 Yen-Ming Lee freebsd_committer 2003-07-02 12:30:32 UTC
State Changed
From-To: open->closed

Committed, thanks.