Bug 52731 - ports/x11-toolkits/qt145 - fix for 5.1-BETA
Summary: ports/x11-toolkits/qt145 - fix for 5.1-BETA
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Kris Kennaway
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-05-27 19:40 UTC by Trevor Johnson
Modified: 2003-08-10 07:45 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Trevor Johnson 2003-05-27 19:40:09 UTC
kludge to make this port compile

Fix: 

LATEST_LINK=	qt1
+USE_GCC=	2.95
 USE_GMAKE=	yes
 USE_X_PREFIX=	yes
 .if defined(MAKE_JOBS)
@@ -39,10 +40,6 @@
 PLIST_SUB+=	VERSION="${VER_MAJ}"

 .include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 500113
-BROKEN=         "Does not compile (bad C++ code)"
-.endif

 MAN1=	moc.1
 .include "${FILESDIR}/man3"--oEmnECS1oI3AGGbeuGPwWFLA5akhsXuZwIr0wmc67LfVssNU
Content-Type: text/plain; name="file.diff"
Content-Transfer-Encoding: 7bit
Content-Disposition: attachment; filename="file.diff"

Index: Makefile
===================================================================
RCS file: /home/ncvs/ports/x11-toolkits/qt145/Makefile,v
retrieving revision 1.61
diff -u -r1.61 Makefile
--- Makefile	18 May 2003 12:20:57 -0000	1.61
+++ Makefile	27 May 2003 18:00:41 -0000
@@ -21,6 +21,7 @@
 COMMENT=	A C++ X GUI toolkit
How-To-Repeat: N/A
Comment 1 Kris Kennaway 2003-05-27 22:21:45 UTC
On Tue, May 27, 2003 at 02:35:29PM -0400, Trevor Johnson wrote:

> kludge to make this port compile

This isn't enough, because every other port that uses qt145 must be
compiled with the same compiler (gcc3 and gcc2 C++ are not
binary-compatible).  Also, gcc295 cannot be used to compile anything
on 5.1 because of a header issue.

Kris
Comment 2 Trevor Johnson 2003-05-30 06:41:55 UTC
> This isn't enough, because every other port that uses qt145 must be
> compiled with the same compiler (gcc3 and gcc2 C++ are not
> binary-compatible).

I guess you are asking which ports use QT 1?  Here is a list:

	audio/musicbox
	games/pp
	math/xgfe
	misc/peq
	net/icqnix

With the appended patch, pp, xgfe and (x)peq are working for me, on
FreeBSD 5.1-BETA/i386.

> Also, gcc295 cannot be used to compile anything
> on 5.1 because of a header issue.

If you'd like me to look into fixing this, please feel free to give me
enough information to reproduce the problem--for instance, what you mean
by "5.1" or better yet, the name of the header you are alluding to.

Index: audio/musicbox/Makefile
===================================================================
RCS file: /home/ncvs/ports/audio/musicbox/Makefile,v
retrieving revision 1.6
diff -u -r1.6 Makefile
--- audio/musicbox/Makefile	1 Mar 2003 14:34:23 -0000	1.6
+++ audio/musicbox/Makefile	30 May 2003 05:29:08 -0000
@@ -18,6 +18,8 @@

 RUN_DEPENDS=	mpg123:${PORTSDIR}/audio/mpg123

+BROKEN=		"compilation error"
+USE_GCC=	2.95
 USE_QT_VER=	1
 DOCS=		ChangeLog README
 EVAL_PREFIX+=	QT1DIR=qt1
Index: audio/musicbox/files/patch-ListView.h
===================================================================
RCS file: audio/musicbox/files/patch-ListView.h
diff -N audio/musicbox/files/patch-ListView.h
--- /dev/null	1 Jan 1970 00:00:00 -0000
+++ audio/musicbox/files/patch-ListView.h	28 May 2003 05:06:28 -0000
@@ -0,0 +1,17 @@
+$FreeBSD$
+
+--- ListView.h.orig	Sun Nov 16 13:56:31 1997
++++ ListView.h	Wed May 28 05:04:41 2003
+@@ -12,12 +12,7 @@
+ #include <qdialog.h>
+ #include "MultiListBox.h"
+
+-#ifdef FreeBSD
+-#include <machine/soundcard.h>
+-#endif
+-#ifdef Linux
+ #include <sys/soundcard.h>
+-#endif
+
+ #define DEVICE 0
+ #define MIXER "/dev/mixer"
Index: audio/musicbox/files/patch-Makefile
===================================================================
RCS file: /home/ncvs/ports/audio/musicbox/files/patch-Makefile,v
retrieving revision 1.3
diff -u -r1.3 patch-Makefile
--- audio/musicbox/files/patch-Makefile	6 May 2002 20:55:05 -0000	1.3
+++ audio/musicbox/files/patch-Makefile	28 May 2003 05:24:27 -0000
@@ -1,5 +1,7 @@
---- Makefile.orig	Wed Nov 12 11:01:58 1997
-+++ Makefile	Sun May  5 14:57:01 2002
+$FreeBSD$
+
+--- Makefile.orig	Wed Nov 12 19:01:58 1997
++++ Makefile	Wed May 28 05:23:56 2003
 @@ -1,7 +1,8 @@
  # change following for your environment
 -INC = /usr/X11R6/include/X11/qt
@@ -17,7 +19,7 @@
  #CFLAGS = -DLinux

 -GCC = gcc
-+GCC ?= cc
++GCC = ${CC}

  ALL = mplayer.o player.o ListView.o clock.o mclock.o mListView.o  \
  	filebrowse.o mfilebrowse.o qktstreelist.o mqktstreelist.o \
Index: games/pp/Makefile
===================================================================
RCS file: /home/ncvs/ports/games/pp/Makefile,v
retrieving revision 1.17
diff -u -r1.17 Makefile
--- games/pp/Makefile	20 Feb 2003 17:32:13 -0000	1.17
+++ games/pp/Makefile	29 May 2003 18:24:42 -0000
@@ -15,6 +15,7 @@
 COMMENT=	Prometeus Project - real time strategy game for X Window System

 WRKSRC=		${WRKDIR}/ppsrc
+USE_GCC=	2.95
 USE_QT_VER=	1
 USE_X_PREFIX=	yes

Index: math/xgfe/Makefile
===================================================================
RCS file: /home/ncvs/ports/math/xgfe/Makefile,v
retrieving revision 1.20
diff -u -r1.20 Makefile
--- math/xgfe/Makefile	7 Mar 2003 06:06:10 -0000	1.20
+++ math/xgfe/Makefile	29 May 2003 18:32:34 -0000
@@ -16,6 +16,7 @@

 RUN_DEPENDS=	gnuplot:${PORTSDIR}/math/gnuplot

+USE_GCC=	2.95
 USE_QT_VER=	1
 USE_X_PREFIX=	yes

Index: misc/peq/Makefile
===================================================================
RCS file: /home/ncvs/ports/misc/peq/Makefile,v
retrieving revision 1.11
diff -u -r1.11 Makefile
--- misc/peq/Makefile	21 Feb 2003 12:48:14 -0000	1.11
+++ misc/peq/Makefile	30 May 2003 05:23:19 -0000
@@ -15,6 +15,7 @@
 MAINTAINER=	gordon@shrubbery.org.za
 COMMENT=	Fortune like program

+USE_GCC=	2.95
 USE_QT_VER=	1

 post-install:
Index: net/icqnix/Makefile
===================================================================
RCS file: /home/ncvs/ports/net/icqnix/Makefile,v
retrieving revision 1.10
diff -u -r1.10 Makefile
--- net/icqnix/Makefile	21 Feb 2003 13:14:44 -0000	1.10
+++ net/icqnix/Makefile	30 May 2003 05:28:43 -0000
@@ -16,6 +16,7 @@

 RUN_DEPENDS=	esdplay:${PORTSDIR}/audio/esound

+BROKEN=		"compilation error"
 GNU_CONFIGURE=	yes
 USE_GMAKE=	yes
 USE_QT_VER=	1
Index: x11-toolkits/qt145/Makefile
===================================================================
RCS file: /home/ncvs/ports/x11-toolkits/qt145/Makefile,v
retrieving revision 1.61
diff -u -r1.61 Makefile
--- x11-toolkits/qt145/Makefile	18 May 2003 12:20:57 -0000	1.61
+++ x11-toolkits/qt145/Makefile	27 May 2003 18:34:23 -0000
@@ -21,6 +21,7 @@
 COMMENT=	A C++ X GUI toolkit

 LATEST_LINK=	qt1
+USE_GCC=	2.95
 USE_GMAKE=	yes
 USE_X_PREFIX=	yes
 .if defined(MAKE_JOBS)
@@ -39,10 +40,6 @@
 PLIST_SUB+=	VERSION="${VER_MAJ}"

 .include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 500113
-BROKEN=         "Does not compile (bad C++ code)"
-.endif

 MAN1=	moc.1
 .include "${FILESDIR}/man3"
-- 
Trevor Johnson
Comment 3 Kris Kennaway 2003-05-30 06:58:51 UTC
On Fri, May 30, 2003 at 01:41:55AM -0400, Trevor Johnson wrote:
> > This isn't enough, because every other port that uses qt145 must be
> > compiled with the same compiler (gcc3 and gcc2 C++ are not
> > binary-compatible).
> 
> I guess you are asking which ports use QT 1?  Here is a list:
> 
> 	audio/musicbox
> 	games/pp
> 	math/xgfe
> 	misc/peq
> 	net/icqnix
> 
> With the appended patch, pp, xgfe and (x)peq are working for me, on
> FreeBSD 5.1-BETA/i386.

Thanks, I'll test this after release.

> > Also, gcc295 cannot be used to compile anything
> > on 5.1 because of a header issue.
> 
> If you'd like me to look into fixing this, please feel free to give me
> enough information to reproduce the problem--for instance, what you mean
> by "5.1" or better yet, the name of the header you are alluding to.

I don't remember the specifics, but when I did my recent sweep for
broken ports I ran into several that were choking on a header provided
by the gcc 2.95 port: it looked like there was something in recent 5.x
headers that gcc 2.95 cannot handle.  You'd have to take a look
through the error logs, either on the bento website or in
bento:/var/portbuild/i386/5/errors.

Kris
Comment 4 Kris Kennaway freebsd_committer 2003-08-10 07:44:55 UTC
State Changed
From-To: open->closed

Patch committed, thanks!