Bug 57106 - racoon libipsec test b0rked
Summary: racoon libipsec test b0rked
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Munechika Sumikawa
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-09-22 21:50 UTC by Bjoern A. Zeeb
Modified: 2003-09-26 17:39 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bjoern A. Zeeb 2003-09-22 21:50:23 UTC
racoon port has the following test:

.if !exists(/usr/lib/libipsec.so.1)
BROKEN=		"You must upgrade the OS"
.endif

but

bz@noc:security/racoon> ls -l /usr/lib/libipsec.so*
lrwxr-xr-x    1 root     wheel          18 Sep 20 22:53 /usr/lib/libipsec.so -> /lib/libipsec.so.1
bz@noc:security/racoon> ls -l /lib/libipsec.so.1
-r--r--r--    1 root     wheel       22988 Sep 20 22:53 /lib/libipsec.so.1

Fix: unsure (don't know if /usr/lib/libipsec.so.1 ever existed)
but I would suggest:



-.if !exists(/usr/lib/libipsec.so.1)
+.if !exists(/usr/lib/libipsec.so.1) && !exists(/lib/libipsec.so.1)
 BROKEN=		"You must upgrade the OS"
.endif--ogy3URXgW0T5QeQaJwZ04sndCzJpfgbjKHLVsHTjO150plBs
Content-Type: text/plain; name="file.diff"
Content-Transfer-Encoding: 7bit
Content-Disposition: attachment; filename="file.diff"

--- Makefile.orig       Mon Sep 22 20:36:35 2003
+++ Makefile    Mon Sep 22 20:36:51 2003
@@ -13,7 +13,7 @@
 MAINTAINER=	sumikawa@FreeBSD.org
 COMMENT=	KAME racoon IKE daemon
How-To-Repeat: 	instal 5.1R and update to HEAD
Comment 1 Kirill Ponomarev freebsd_committer 2003-09-22 22:00:55 UTC
Responsible Changed
From-To: freebsd-ports-bugs->sumikawa

Over to maintainer
Comment 2 Munechika Sumikawa freebsd_committer 2003-09-26 17:39:25 UTC
State Changed
From-To: open->closed

Commited, thanks.