Bug 58663 - Time::HiRes included with perl-5.8
Summary: Time::HiRes included with perl-5.8
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Yen-Ming Lee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-10-29 00:40 UTC by Jeremy Chadwick
Modified: 2003-10-30 18:32 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jeremy Chadwick 2003-10-29 00:40:17 UTC
Time::HiRes is included with perl-5.8.  This was verified using the latest perl-5.8
ports build (perl-5.8.1_2), but likely applies to 5.8.0 as well:

gabriel# find /usr/local/lib/perl5 -name "*HiRes*" -ls
3154942   28 -r--r--r--    1 root   wheel   12612 Oct 28 16:27 /usr/local/lib/perl5/5.8.1/mach/Time/HiRes.pm
3155536    4 drwxr-xr-x    2 root   wheel     512 Oct 28 16:27 /usr/local/lib/perl5/5.8.1/mach/auto/Time/HiRes
3155537   32 -r-xr-xr-x    1 root   wheel   15716 Oct 28 16:27 /usr/local/lib/perl5/5.8.1/mach/auto/Time/HiRes/HiRes.so
3155538    0 -r--r--r--    1 root   wheel       0 Oct 28 16:27 /usr/local/lib/perl5/5.8.1/mach/auto/Time/HiRes/HiRes.bs
3157586   16 -rw-r--r--    1 root   wheel    6229 Oct 28 16:27 /usr/local/lib/perl5/5.8.1/man/man3/Time::HiRes.3.gz
gabriel# pkg_info | grep HiRes
gabriel#

Fix: 

Move the BUILD_DEPENDS entry for ports/devel/p5-Time-HiRes into the
PERL_LEVEL check section near the bottom of the Makefile.

Sorry I didn't catch this one with my other PR, guys!  :-)
How-To-Repeat: Install razor-agents and find two versions of Time::HiRes floating around.
Comment 1 Jeremy Chadwick 2003-10-29 00:51:26 UTC
  Actually, I just realised there's a lot more than just Time::HiRes
which should be moved into BUILD_DEPENDS for anything less than
perl 5.8.  I should have done a more thorough review.

  BUILD_DEPENDS should have p5-Digest-Nilsimsa and p5-URI.  These
don't come with perl 5.0, 5.6, or 5.8 (AFAIK).

  Builds older than 5.8 (possibly 5.6; see above comment) should
also depend on p5-Digest-SHA1, p5-Net-DNS, p5-Test-Simple, and
p5-Time-HiRes.

  That's all I've found for now, other than possibly moving the
RUN_DEPENDS assignment below the PERL_LEVEL check (I'm under the
impression that most of these modules are required to be installed
for razor-agents to __run__, not just build).  The present method
will only check for modules included in the default BUILD_DEPENDS
up at the top of the Makefile.

 Hope this helps!

On Tue, Oct 28, 2003 at 04:40:17PM -0800, FreeBSD-gnats-submit@FreeBSD.org wrote:
> Thank you very much for your problem report.
> It has the internal identification `ports/58663'.
> The individual assigned to look at your
> report is: freebsd-ports-bugs. 
> 
> You can access the state of your problem report at any time
> via this link:
> 
> http://www.freebsd.org/cgi/query-pr.cgi?pr=58663
> 
> >Category:       ports
> >Responsible:    freebsd-ports-bugs
> >Synopsis:       Time::HiRes included with perl-5.8
> >Arrival-Date:   Tue Oct 28 16:40:17 PST 2003
Comment 2 Jeremy Chadwick 2003-10-29 00:59:01 UTC
  One more update: looks like Digest::SHA1 needs to be included
regardless (meaning it needs to be put back up into the initial
pre-requisite BUILD_DEPENDS list).

  perl-5.8 has a Digest.pm file which apparently includes SHA1,
but doesn't have an actual Digest::SHA1 module.

  Without this, razor-agents won't build.

On Tue, Oct 28, 2003 at 04:40:17PM -0800, FreeBSD-gnats-submit@FreeBSD.org wrote:
> Thank you very much for your problem report.
> It has the internal identification `ports/58663'.
> The individual assigned to look at your
> report is: freebsd-ports-bugs. 
> 
> You can access the state of your problem report at any time
> via this link:
> 
> http://www.freebsd.org/cgi/query-pr.cgi?pr=58663
> 
> >Category:       ports
> >Responsible:    freebsd-ports-bugs
> >Synopsis:       Time::HiRes included with perl-5.8
> >Arrival-Date:   Tue Oct 28 16:40:17 PST 2003
Comment 3 Jeremy Chadwick 2003-10-29 01:34:16 UTC
  Another update: looks as if p5-Net-DNS _doesn't_ come
with perl 5.8.  I'm not sure how the copy I had was still
on the box (especially with such timestamps); it must've
been a broken build I was working on.

  p5-Net-DNS should be part of the pre-requisites for
BUILD_DEPENDS after all.

On Tue, Oct 28, 2003 at 04:40:17PM -0800, FreeBSD-gnats-submit@FreeBSD.org wrote:
> Thank you very much for your problem report.
> It has the internal identification `ports/58663'.
> The individual assigned to look at your
> report is: freebsd-ports-bugs. 
> 
> You can access the state of your problem report at any time
> via this link:
> 
> http://www.freebsd.org/cgi/query-pr.cgi?pr=58663
> 
> >Category:       ports
> >Responsible:    freebsd-ports-bugs
> >Synopsis:       Time::HiRes included with perl-5.8
> >Arrival-Date:   Tue Oct 28 16:40:17 PST 2003
Comment 4 Mark Linimon freebsd_committer freebsd_triage 2003-10-30 07:16:23 UTC
Responsible Changed
From-To: freebsd-ports-bugs->leeym

Over to maintainer of mail/razor-agents, which AFAICT this PR 
concerns.
Comment 5 Yen-Ming Lee freebsd_committer 2003-10-30 18:32:41 UTC
State Changed
From-To: open->closed

Committed, thanks.