Bug 59725 - [NEW PORT] net/aMule (supersedes ports/59252) --Fixed deps/bugs--
Summary: [NEW PORT] net/aMule (supersedes ports/59252) --Fixed deps/bugs--
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: FreeBSD Ports Bugs (Mailing List)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-11-27 12:20 UTC by ganael.laplanche
Modified: 2003-11-27 12:28 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ganael.laplanche 2003-11-27 12:20:15 UTC
aMule is a multiplatform fork of xMule client using wxWindows class library.

Fix: --------------- aMule-1.1.2.shar begins here ---------------


--------------- aMule-1.1.2.shar ends here -----------------04yEfQb0S0pLGvelEkOouwdJm9ebzf9Uw1GpKhS0OD7awqed
Content-Type: text/plain; name="file.shar"
Content-Transfer-Encoding: 7bit
Content-Disposition: attachment; filename="file.shar"

# This is a shell archive.  Save it in a file, remove anything before
# this line, and then unpack it by entering "sh file".  Note, it may
# create directories; files and directories will be owned by you and
# have default permissions.
#
# This archive contains:
#
#	amule
#	amule/README.html
#	amule/pkg-descr
#	amule/pkg-plist
#	amule/distinfo
#	amule/Makefile
#	amule/pkg-message
#
echo c - amule
mkdir -p amule > /dev/null 2>&1
echo x - amule/README.html
sed 's/^X//' >amule/README.html << 'END-of-amule/README.html'
X<!DOCTYPE html PUBLIC "-//IETF//DTD HTML 2.0//EN">
X
X<html>
X  <head>
X    <title>The FreeBSD Ports Collection (net/amule)</title>
X  </head>
X
X  <body>
X    <h1>The FreeBSD Ports Collection (net/amule)</h1>
X    <hr>
X
X    <p>You are now in the directory for the port "net/amule".</p>
X
X    <p>The package name of this port is "aMule-1.1.2".</p>
X
X    <p>This is the one-line description for this port:</p>
X    <hr>
X
X    <p>
XaNOTHER eMule P2P Client
X    </p>
X    <hr>
X
X    <p>Please read the "<a href="pkg-descr">description file</a>" for a
X    longer description and/or visit the <a href="http://sourceforge.net/projects/amule/">web site</a> for futher informations.</p>
X
X    <p>If needed, you may contact the <a href=
X    "mailto:ganael.laplanche@martymac.com">maintainer</a> of this port or the port <a href=
X    "mailto:ports@FreeBSD.org">mailing-list</a>.</p>
X
X    <p>This port requires package(s) "" to build.</p>
X
X    <p>This port requires package(s) "" to run.</p>
X
X    <p>Go to the <a href="../../README.html">top of the ports tree</a> for
X    a summary on how to use the ports collection.</p>
X    <hr>
X
X    <p><a href="../README.html">Go up one level</a> | <a href=
X    "../../README.html">Go to top of ports tree</a></p>
X  </body>
X</html>
X
END-of-amule/README.html
echo x - amule/pkg-descr
sed 's/^X//' >amule/pkg-descr << 'END-of-amule/pkg-descr'
X[ from README ]
X
XThis program is a multiplatform fork of
X xMule client using wxWindows class library.
X
XWWW: http://sourceforge.net/projects/amule/
END-of-amule/pkg-descr
echo x - amule/pkg-plist
sed 's/^X//' >amule/pkg-plist << 'END-of-amule/pkg-plist'
Xbin/amule
Xbin/amule-ed2k-handler
Xshare/gnome/applications/amule.desktop
Xshare/gnome/pixmaps/amule.xpm
Xshare/gnome/locale/de/LC_MESSAGES/amule.mo
Xshare/gnome/locale/ee/LC_MESSAGES/amule.mo
Xshare/gnome/locale/es/LC_MESSAGES/amule.mo
Xshare/gnome/locale/es_MX/LC_MESSAGES/amule.mo
Xshare/gnome/locale/fr/LC_MESSAGES/amule.mo
Xshare/gnome/locale/it/LC_MESSAGES/amule.mo
Xshare/gnome/locale/ko/LC_MESSAGES/amule.mo
Xshare/gnome/locale/pl/LC_MESSAGES/amule.mo
Xshare/gnome/locale/tr/LC_MESSAGES/amule.mo
X@unexec rmdir %D/share/gnome/locale/de/LC_MESSAGES 2>/dev/null || true
X@unexec rmdir %D/share/gnome/locale/de 2>/dev/null || true
X@unexec rmdir %D/share/gnome/locale/ee/LC_MESSAGES 2>/dev/null || true
X@unexec rmdir %D/share/gnome/locale/ee 2>/dev/null || true
X@unexec rmdir %D/share/gnome/locale/es/LC_MESSAGES 2>/dev/null || true
X@unexec rmdir %D/share/gnome/locale/es 2>/dev/null || true
X@unexec rmdir %D/share/gnome/locale/es_MX/LC_MESSAGES 2>/dev/null || true
X@unexec rmdir %D/share/gnome/locale/es_MX 2>/dev/null || true
X@unexec rmdir %D/share/gnome/locale/fr/LC_MESSAGES 2>/dev/null || true
X@unexec rmdir %D/share/gnome/locale/fr 2>/dev/null || true
X@unexec rmdir %D/share/gnome/locale/it/LC_MESSAGES 2>/dev/null || true
X@unexec rmdir %D/share/gnome/locale/it 2>/dev/null || true
X@unexec rmdir %D/share/gnome/locale/ko/LC_MESSAGES 2>/dev/null || true
X@unexec rmdir %D/share/gnome/locale/ko 2>/dev/null || true
X@unexec rmdir %D/share/gnome/locale/pl/LC_MESSAGES 2>/dev/null || true
X@unexec rmdir %D/share/gnome/locale/pl 2>/dev/null || true
X@unexec rmdir %D/share/gnome/locale/tr/LC_MESSAGES 2>/dev/null || true
X@unexec rmdir %D/share/gnome/locale/tr 2>/dev/null || true
END-of-amule/pkg-plist
echo x - amule/distinfo
sed 's/^X//' >amule/distinfo << 'END-of-amule/distinfo'
XMD5 (aMule-1.1.2.tar.gz) = caf7805d1000360ca84db9d05ec587d0
END-of-amule/distinfo
echo x - amule/Makefile
sed 's/^X//' >amule/Makefile << 'END-of-amule/Makefile'
X# New ports collection makefile for:	amule
X# Date created:		Wed Nov 05 09:30:00 UTC 2003
X# Whom:			Ganael LAPLANCHE <ganael.laplanche@martymac.com>
X#
X# $FreeBSD$
X#
X
X# Based on xmule's port
X
XPORTNAME=	aMule
XPORTVERSION=	1.1.2
XCATEGORIES=	net
XMASTER_SITES=		${MASTER_SITE_SOURCEFORGE}
XMASTER_SITE_SUBDIR=	amule
X
XMAINTAINER=	ganael.laplanche@martymac.com
XCOMMENT=	aNOTHER eMule P2P Client
X
XFETCH_DEPENDS=	wget:${PORTSDIR}/ftp/wget:install
XEXTRACT_DEPENDS=	automake:${PORTSDIR}/devel/automake:install \
X			autoconf:${PORTSDIR}/devel/autoconf:install
XLIB_DEPENDS=	intl.5:${PORTSDIR}/devel/gettext:install \
X		wx_gtk-2.4.0:${PORTSDIR}/x11-toolkits/wxgtk:install
X
XUSE_X_PREFIX=	yes
XUSE_GNOME=	gnomehier \
X		gnomehack \
X		gnomeprefix
X# Gtk12 or gtk2 will be added here depending on
X# what is detected at the end of this script
X
XUSE_REINPLACE=	yes
X
XUSE_GMAKE=	yes
XGNU_CONFIGURE=	yes
XCONFIGURE_ARGS=	--without-included-gettext \
X		--with-libintl-prefix=${LOCALBASE} \
X		--with-libiconv-prefix=${LOCALBASE} \
X		--with-wx-config=${WX_CONFIG} \
X		--with-optimize
X
XCONFIGURE_ENV=	CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
X		LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib ${PTHREAD_LIBS}"
X
XWX_CONFIG?=	${X11BASE}/bin/wx-config
X
Xpost-extract:
X# Create Makefile.in's
X	@${ECHO} "******************"
X	@${ECHO} "Running autogen.sh"
X	@cd ${WRKSRC} && ${SH} autogen.sh
X	@${ECHO} "autogen.sh : done."
X	@${ECHO} "******************"
X
Xpre-patch:
X# Patches
X	@${ECHO} "******************************************"
X	@${ECHO} "Applying SysTray.cpp and gsocket.c patches"
X	@${REINPLACE_CMD} -E \
X		-e '/^\#include\ \<net\/if\.h\>/{x;s/^/\#include\ \<netinet\/in\.h\>/;x;G;}' \
X		${WRKSRC}/src/SysTray.cpp
X	@${REINPLACE_CMD} -E \
X		-e '/^\#include\ <netinet\/in\.h\>/{x;s/^/\#define\ MSG_NOSIGNAL\ 0x4000/;x;G;}' \
X		${WRKSRC}/src/gsocket.c
X	@${ECHO} "patches : done."
X	@${ECHO} "******************************************"
X
X# Do not install a generic named ed2k binary
X	@${ECHO} "******************************"
X	@${ECHO} "Applying Makefile.in's patches"
X	@${REINPLACE_CMD} -E \
X		-e 's/^(bin_PROGRAMS.+)amule ed2k/bin_PROGRAMS\ \=\ amule/' \
X		${WRKSRC}/src/Makefile.in
X	@${REINPLACE_CMD} -E \
X		-e 's/^(bin_PROGRAMS.+)ed2k.+\([A-Z]+\)/\1/' \
X		${WRKSRC}/src/Makefile.in
X	@${ECHO} "patches : done."
X	@${ECHO} "******************************"
X
Xpost-configure:
X# Patch for po's Makefile
X	@${ECHO} "****************************"
X	@${ECHO} "Applying po's Makefile patch"
X	@${REINPLACE_CMD} -E \
X		-e 's/^(PACKAGE\ +\=\ +)/PACKAGE\ \=\ amule/' \
X		${WRKSRC}/po/Makefile
X	@${ECHO} "patch : done."
X	@${ECHO} "****************************"
X
Xpost-build:
X# Build the generic named ed2k binary
X# It will installed in an adhoc fashion
X	@cd ${BUILD_WRKSRC}/src && ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ed2k
X
Xpost-install:
X# Do not install a generic named ed2k binary
X# Install it under a more specific name
X	@${INSTALL_PROGRAM} ${WRKSRC}/src/ed2k \
X		${PREFIX}/bin/amule-ed2k-handler
X
X# Displays the pkg-message file
X	@${CAT} pkg-message
X
X.include <bsd.port.pre.mk>
X
X.if exists(${WX_CONFIG})
X# detect if wxgtk was linked against gtk1 or gtk2
XDECISION_GTK_1_OR_2!= ${WX_CONFIG} --static --libs
X.else
XDECISION_GTK_1_OR_2= ""
X.endif
X
X.if ${DECISION_GTK_1_OR_2:M*glib-2.0} != ""
XUSE_GNOME+= gtk20
X.else
XUSE_GNOME+= gtk12
X.endif
X
X.include <bsd.port.post.mk>
END-of-amule/Makefile
echo x - amule/pkg-message
sed 's/^X//' >amule/pkg-message << 'END-of-amule/pkg-message'
X#############################################
X  aMule is now ready !
X
X  http://www.sourceforge.net/projects/amule
X  http://amule.sourceforge.net
X#############################################
END-of-amule/pkg-message
exit
Comment 1 sergei freebsd_committer 2003-11-27 12:28:25 UTC
State Changed
From-To: open->closed

Duplicate of ports/59724.