Bug 59993 - databases/mysql-connector-java requires JDK 1.4.x to build
databases/mysql-connector-java requires JDK 1.4.x to build
Status: Closed FIXED
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s)
Any Any
: Normal Affects Only Me
Assigned To: Mark Linimon
Depends on:
  Show dependency treegraph
Reported: 2003-12-06 18:20 UTC by m.seaman
Modified: 2003-12-29 21:39 UTC (History)
1 user (show)

See Also:

mysql-connector-java.diff (1.47 KB, patch)
2003-12-06 18:20 UTC, m.seaman
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description m.seaman 2003-12-06 18:20:15 UTC
Noticed by: Aristedes Maniatis

As documented at


MySQL Connector/J really does need JDK 1.4.x to compile.  Use of
apache-ant appears to side-step all of the effects of the USE_JAVA
knob from bsd.java.mk, so all previous testing was actually using JDK 1.4.2
to do the compilation step.

Since the distfile contains a pre-compiled .jar file, which will work with
any Java-2 JVM, provide a WITHOUT_BUILD option
Comment 1 Mark Linimon freebsd_committer 2003-12-29 02:26:12 UTC
Responsible Changed
From-To: freebsd-ports-bugs->linimon

I'll take a look, if I can ever get my JDK updated.
Comment 2 Mark Linimon freebsd_committer 2003-12-29 21:38:50 UTC
State Changed
From-To: open->closed

Committed, thanks.