Bug 61663 - [patch] x11/eterm fails at start of build
Summary: [patch] x11/eterm fails at start of build
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Jimmy Olgeni
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-01-21 03:30 UTC by David Fleck
Modified: 2004-05-01 17:43 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David Fleck 2004-01-21 03:30:14 UTC
 >> Checksum OK for Eterm-0.9.2.tar.gz.
 ===>  Patching for eterm-0.9.2_1
 ===>  Applying FreeBSD patches for eterm-0.9.2_1
 rm: /usr/ports/x11/eterm/work/Eterm-0.9.2/themes/Eterm/*.orig: No such file or directory
 *** Error code 1
 
 This error is caused by changes introduced into the Makefile in revision 1.45. 
 Three 'rm' statements will cause the build to fail if the port directory is
 clean and there are no files to delete.
 
 The following patch backs these changes out:
 
 *** Makefile    Tue Jan 20 21:10:02 2004
 --- Makefile.patch      Tue Jan 20 21:09:48 2004
 ***************
 *** 39,47 ****
   .endif
 
   post-patch:
 !       @${RM} ${WRKSRC}/themes/Eterm/*.orig
 !       @${RM} ${WRKSRC}/themes/auto/*.orig
 !       @${RM} ${WRKSRC}/themes/trans/*.orig
 
   post-install:
         @${CHMOD} 4711 ${PREFIX}/bin/Eterm
 --- 39,47 ----
   .endif
 
   post-patch:
 !       -@${RM} ${WRKSRC}/themes/Eterm/*.orig
 !       -@${RM} ${WRKSRC}/themes/auto/*.orig
 !       -@${RM} ${WRKSRC}/themes/trans/*.orig
 
   post-install:
         @${CHMOD} 4711 ${PREFIX}/bin/Eterm
Comment 1 Sergei Kolobov freebsd_committer 2004-01-21 09:20:36 UTC
Responsible Changed
From-To: freebsd-ports-bugs->olgeni

Over to maintainer.
Comment 2 David Fleck 2004-01-21 14:04:27 UTC
I should clarify this line:

  The following patch backs these changes out:

the patch does not back the changes out, it keeps the changes but makes
them ignore non-zero exit status for each 'rm' - which is what is
returned if there is no file to delete.

--
David Fleck
david.fleck@mchsi.com
Comment 3 Jimmy Olgeni freebsd_committer 2004-05-01 17:42:26 UTC
State Changed
From-To: open->closed

Fixed, thanks!