Bug 63170 - jmode-skk should require skkserv OR dbskkd
jmode-skk should require skkserv OR dbskkd
Status: Closed FIXED
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s)
Latest
Any Any
: Normal Affects Only Me
Assigned To: FreeBSD ports mailing list
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-21 14:10 UTC by tamo
Modified: 2004-02-22 14:59 UTC (History)
0 users

See Also:


Attachments
Makefile (719 bytes, text/plain)
2004-02-21 14:10 UTC, tamo
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description tamo 2004-02-21 14:10:17 UTC
jmode-skk requires a SKK server.

There are several SKK servers.
( The oldest one is skkserv. rskkserv seems obsolete.
  dbskkd is newer and faster and more secure one.)

jmode-skk should require not only skkserv but one of the SKK servers.

Fix: attached /usr/ports/japanese/jmode-skk/Makefile fixes the problem.
see /usr/ports/japanese/skkinput3/Makefile.
	
How-To-Repeat: portupgrade -N jmode-skk
(this installs skkserv and his dictionary even if I have dbskkd already installed)
Comment 1 MANTANI Nobutaka freebsd_committer 2004-02-22 14:56:00 UTC
State Changed
From-To: open->closed

Committed, thanks! 
Please send the unified diff next time.