Bug 63489 - getpwent segfault when using NIS groups to restrict logins
Summary: getpwent segfault when using NIS groups to restrict logins
Status: Open
Alias: None
Product: Base System
Classification: Unclassified
Component: bin (show other bugs)
Version: 4.7-RELEASE
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-bugs mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-02-28 14:10 UTC by Daniel Ellard
Modified: 2018-05-20 23:40 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Ellard 2004-02-28 14:10:22 UTC
 
 "top" or "finger foo" segfaults on a machine with logins limited to a
 subset of NIS user groups.  (There might be other apps that die the
 same way, but these are the first two I found, and top is especially
 important to me.) This only happens when logins are restricted;
 letting in everyone (i.e.  "+:::::::::") doesn't cause the problem. 
 The programs die in getpwent.
 
 How-To-Repeat:
 
 Run "top" or "finger foo" on a machine with logins limited to a subset
 of NIS user groups.  (There might be other apps that die the same way,
 but these are the first two I found.)
 
 Specific steps:
 
 Note:  if you already have any lines of the form "+@xyz:::::::::" in
 your /etc/passwd file, then you can skip steps 1 and 2.
 
 	1.  Create an NIS group of users with a specific name (in this
 		example, I'll call it foo).
 
 	2.  Use vipw to edit /etc/passwd.  Comment out any references
 		to NIS groups (i.e.  "+:::::::::").  Add
 		"+@foo:::::::::" as the last line.
 
 	3.  Run "top" or "finger foo".  ("foo" doesn't have to be the
 		name of a real user -- it can be anything.  The point
 		is to have finger try to look up a user.)
 
 		Watch as it segfaults in getpwent.
Comment 1 Mark Linimon freebsd_committer freebsd_triage 2004-03-29 20:27:26 UTC
Responsible Changed
From-To: gnats-admin->freebsd-bugs

I forgot to reassign it when I cleaned up the formatting.  Oops.
Comment 2 Maxim Konovalov freebsd_committer 2004-07-17 23:27:16 UTC
State Changed
From-To: open->closed

Duplicate of bin/45990.
Comment 3 Maxim Konovalov freebsd_committer 2004-07-18 00:23:50 UTC
State Changed
From-To: closed->open

It looks like a different bug in getpwent() code.
Comment 4 Eitan Adler freebsd_committer freebsd_triage 2017-12-31 07:59:23 UTC
For bugs matching the following criteria:

Status: In Progress Changed: (is less than) 2014-06-01

Reset to default assignee and clear in-progress tags.

Mail being skipped